summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric Haszlakiewicz <erh+git@nimenees.com>2012-03-31 22:51:39 -0500
committerKeith Derrick <keith.derrick@palm.com>2012-04-02 07:53:25 -0700
commit30c6c4a1be41a59ea9335bc3566371276a72763f (patch)
tree4135207e7551ba7027704a262511c49f8e7e881c /Makefile.am
parentbb7978c95ffbb1afd78767309ef3c30a93ee62ab (diff)
downloadjson-c-30c6c4a1be41a59ea9335bc3566371276a72763f.tar.gz
Split the json_tokener_parse tests off from test1 into their own test and add several more cases to check various incremental parsing situations.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index e31da77..07e610d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -38,7 +38,7 @@ libjson_la_SOURCES = \
linkhash.c \
printbuf.c
-check_PROGRAMS = test1 test2 test4 test_parse_int64 test_null test_cast
+check_PROGRAMS = test1 test2 test4 test_parse_int64 test_null test_cast test_parse
test1_SOURCES = test1.c
test1_LDADD = $(lib_LTLIBRARIES)
@@ -58,7 +58,10 @@ test_null_LDADD = $(lib_LTLIBRARIES)
test_cast_SOURCES = test_cast.c
test_cast_LDADD = $(lib_LTLIBRARIES)
-TESTS = test1.test test2.test test4.test parse_int64.test test_null.test test_cast.test
+test_parse_SOURCES = test_parse.c
+test_parse_LDADD = $(lib_LTLIBRARIES)
+
+TESTS = test1.test test2.test test4.test parse_int64.test test_null.test test_cast.test test_parse.test
EXTRA_DIST += $(TESTS)
testsubdir=testSubDir
TESTS_ENVIRONMENT = top_builddir=$(top_builddir)