summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEric Hawicz <erh+git@nimenees.com>2021-05-01 15:21:31 -0400
committerGitHub <noreply@github.com>2021-05-01 15:21:31 -0400
commitcd7109f767a6d9f20caa9d10fbf4eab9c5262e7a (patch)
tree8d304f648b53bf7c81d2b087f03952f89c8babb2 /CMakeLists.txt
parent78e390a26155e5c6d71cc5b742b3c4cb2d4b3fe6 (diff)
parentba181548bca566d320899f7b78e5b753c0dba611 (diff)
downloadjson-c-cd7109f767a6d9f20caa9d10fbf4eab9c5262e7a.tar.gz
Merge pull request #696 from ssrlive/master
To avoid target exe file export JSON functions.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 887b4d5..e870cca 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -79,6 +79,10 @@ include(CMakePackageConfigHelpers)
option(BUILD_SHARED_LIBS "Default to building shared libraries" ON)
option(BUILD_STATIC_LIBS "Default to building static libraries" ON)
+if (BUILD_SHARED_LIBS)
+ add_definitions(-D JSON_C_DLL)
+endif()
+
# Generate a release merge and test it to verify the correctness of republishing the package.
ADD_CUSTOM_TARGET(distcheck
COMMAND make package_source