summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Tolnay <dtolnay@gmail.com>2015-06-27 10:16:13 -0700
committerDavid Tolnay <dtolnay@gmail.com>2015-06-27 11:25:01 -0700
commite6371712fff2e899afd312473584bb1223d7cf86 (patch)
tree2f042631ef7b158802fcf41c26c5bd5cfc9357e6 /Makefile.am
parentd7e35101c537a8ec7c86e8e19313e8a20dd72ce3 (diff)
downloadjq-e6371712fff2e899afd312473584bb1223d7cf86.tar.gz
flag to enable gcov and coveralls
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 12 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 8598f4c..15d1b29 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -55,6 +55,12 @@ else
NO_VALGRIND = 1
endif
+### Code coverage with gcov
+
+if ENABLE_GCOV
+AM_CFLAGS += --coverage --no-inline
+endif
+
### Error injection for testing
if ENABLE_ERROR_INJECTION
@@ -176,11 +182,15 @@ dist-clean-local:
# Not sure why this doesn't get cleaned up automatically, guess
# automake used to man pages which are hand coded?
# 'make clean' doesn't delete the manpage if it can't be rebuilt
-.PHONY: clean-local-docs
clean-local-docs:
if ENABLE_DOCS
rm -f jq.1
endif
-clean-local: clean-local-docs
+clean-local-gcov:
+ rm -f *.gcno *.gcda *.gcov
+
+clean-local: clean-local-docs clean-local-gcov
rm -f version.h .remake-version-h
+
+.PHONY: clean-local-docs clean-local-gcov