summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorStephen Dolan <mu@netsoc.tcd.ie>2013-06-22 20:53:03 +0100
committerStephen Dolan <mu@netsoc.tcd.ie>2013-06-22 20:53:03 +0100
commit3a295c659b35cc3d925e54e0f2bc026a6ce71cdb (patch)
tree0057d6c78b50e44f23ad3c83aca061cd8ea0370f /Makefile.am
parente8643787cf254541e67b3a02c91f728fa1ae2620 (diff)
downloadjq-3a295c659b35cc3d925e54e0f2bc026a6ce71cdb.tar.gz
Fix distcheck.
Update list of files to be distributed.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 4 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 0c9b0db..67415e1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,9 +1,8 @@
### C source files to be built and distributed.
-LIBJQ_INCS = jq_parser.h builtin.h bytecode.h compile.h \
- forkable_stack.h frame_layout.h jv_alloc.h jv_dtoa.h \
- jv_parse.h jv_unicode.h locfile.h opcode.h opcode_list.h \
- parser.y jv_utf8_tables.h lexer.l
+LIBJQ_INCS = jq_parser.h builtin.h bytecode.h compile.h exec_stack.h \
+ jv_alloc.h jv_dtoa.h jv_parse.h jv_unicode.h locfile.h opcode.h \
+ opcode_list.h parser.y jv_utf8_tables.h lexer.l
LIBJQ_SRC = locfile.c opcode.c bytecode.c compile.c execute.c builtin.c \
jv.c jv_parse.c jv_print.c jv_dtoa.c jv_unicode.c jv_aux.c jv_file.c \
@@ -120,7 +119,7 @@ DOC_FILES = docs/content docs/public docs/templates docs/site.yml \
EXTRA_DIST = config.h.in $(man_MANS) $(TESTS) \
$(TEST_LOG_COMPILER) gen_utf8_tables.py jq.spec \
$(DOC_FILES) scripts/version \
- parser.h parser.c lexer.h lexer.c
+ parser.h parser.c lexer.h lexer.c libjq.map
# README.md is expected in Github projects, good stuff in it, so we'll
# distribute it and install it with the package in the doc directory.