summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorDavid Lord <davidism@gmail.com>2019-10-04 11:22:50 -0700
committerDavid Lord <davidism@gmail.com>2019-10-04 11:22:50 -0700
commit38165dfeba9d73de52ce90442e7ec8f491dceda7 (patch)
treeac7bab59aec84198b64e79aa40bd634685b6f705 /setup.py
parentd3b976b7f8bf9e99b47feec92bdc00039a6c5c56 (diff)
parent0fee409131d58d2912847450717b9312e0a9513d (diff)
downloadjinja2-38165dfeba9d73de52ce90442e7ec8f491dceda7.tar.gz
Merge branch '2.10.x'
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py119
1 files changed, 43 insertions, 76 deletions
diff --git a/setup.py b/setup.py
index 49bdc18..c66b918 100644
--- a/setup.py
+++ b/setup.py
@@ -1,87 +1,54 @@
-# -*- coding: utf-8 -*-
-"""
-Jinja2
-~~~~~~
+import io
+import re
-Jinja2 is a template engine written in pure Python. It provides a
-`Django`_ inspired non-XML syntax but supports inline expressions and
-an optional `sandboxed`_ environment.
-
-Nutshell
---------
-
-Here a small example of a Jinja template::
-
- {% extends 'base.html' %}
- {% block title %}Memberlist{% endblock %}
- {% block content %}
- <ul>
- {% for user in users %}
- <li><a href="{{ user.url }}">{{ user.username }}</a></li>
- {% endfor %}
- </ul>
- {% endblock %}
-
-Philosophy
-----------
-
-Application logic is for the controller but don't try to make the life
-for the template designer too hard by giving him too few functionality.
-
-For more information visit the new `Jinja2 webpage`_ and `documentation`_.
-
-.. _sandboxed: https://en.wikipedia.org/wiki/Sandbox_(computer_security)
-.. _Django: https://www.djangoproject.com/
-.. _Jinja2 webpage: http://jinja.pocoo.org/
-.. _documentation: http://jinja.pocoo.org/2/documentation/
-"""
+from setuptools import find_packages
from setuptools import setup
+with io.open("README.rst", "rt", encoding="utf8") as f:
+ readme = f.read()
+
+with io.open("jinja2/__init__.py", "rt", encoding="utf8") as f:
+ version = re.search(r'__version__ = "(.*?)"', f.read(), re.M).group(1)
setup(
- name='Jinja2',
- version='2.11.dev',
- url='http://jinja.pocoo.org/',
+ name="Jinja2",
+ version=version,
+ url="https://palletsprojects.com/p/jinja/",
project_urls={
- 'Documentation': 'https://jinja.palletsprojects.com/',
- 'Code': 'https://github.com/pallets/jinja/',
- 'Issue tracker': 'https://github.com/pallets/jinja/issues',
+ "Documentation": "https://jinja.palletsprojects.com/",
+ "Code": "https://github.com/pallets/jinja",
+ "Issue tracker": "https://github.com/pallets/jinja/issues",
},
- license='BSD-3-Clause',
- author='Armin Ronacher',
- author_email='armin.ronacher@active-4.com',
- description='A small but fast and easy to use stand-alone template '
- 'engine written in pure python.',
- long_description=__doc__,
- # jinja is egg safe. But we hate eggs
- zip_safe=False,
+ license="BSD-3-Clause",
+ author="Armin Ronacher",
+ author_email="armin.ronacher@active-4.com",
+ maintainer="Pallets",
+ maintainer_email="contact@palletsprojects.com",
+ description="A very fast and expressive template engine.",
+ long_description=readme,
classifiers=[
- 'Development Status :: 5 - Production/Stable',
- 'Environment :: Web Environment',
- 'Intended Audience :: Developers',
- 'License :: OSI Approved :: BSD License',
- 'Operating System :: OS Independent',
- 'Programming Language :: Python',
- 'Programming Language :: Python :: 2',
- 'Programming Language :: Python :: 2.7',
- 'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.4',
- 'Programming Language :: Python :: 3.5',
- 'Programming Language :: Python :: 3.6',
- 'Programming Language :: Python :: 3.7',
- 'Programming Language :: Python :: Implementation :: CPython',
- 'Programming Language :: Python :: Implementation :: PyPy',
- 'Topic :: Internet :: WWW/HTTP :: Dynamic Content',
- 'Topic :: Software Development :: Libraries :: Python Modules',
- 'Topic :: Text Processing :: Markup :: HTML'
+ "Development Status :: 5 - Production/Stable",
+ "Environment :: Web Environment",
+ "Intended Audience :: Developers",
+ "License :: OSI Approved :: BSD License",
+ "Operating System :: OS Independent",
+ "Programming Language :: Python",
+ "Programming Language :: Python :: 2",
+ "Programming Language :: Python :: 2.7",
+ "Programming Language :: Python :: 3",
+ "Programming Language :: Python :: 3.5",
+ "Programming Language :: Python :: 3.6",
+ "Programming Language :: Python :: 3.7",
+ "Programming Language :: Python :: Implementation :: CPython",
+ "Programming Language :: Python :: Implementation :: PyPy",
+ "Topic :: Internet :: WWW/HTTP :: Dynamic Content",
+ "Topic :: Software Development :: Libraries :: Python Modules",
+ "Topic :: Text Processing :: Markup :: HTML",
],
- packages=['jinja2'],
- python_requires=">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*",
- install_requires=['MarkupSafe>=0.23'],
- extras_require={'i18n': ['Babel>=0.8']},
+ packages=find_packages(),
+ python_requires=">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*, !=3.4.*",
include_package_data=True,
- entry_points="""
- [babel.extractors]
- jinja2 = jinja2.ext:babel_extract[i18n]
- """
+ install_requires=["MarkupSafe>=0.23"],
+ extras_require={"i18n": ["Babel>=0.8"]},
+ entry_points={"babel.extractors": ["jinja2 = jinja2.ext:bable_extract[i18n]"]},
)