summaryrefslogtreecommitdiff
path: root/drivers/alsa_midi/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'drivers/alsa_midi/Makefile.am')
-rw-r--r--drivers/alsa_midi/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/drivers/alsa_midi/Makefile.am b/drivers/alsa_midi/Makefile.am
new file mode 100644
index 0000000..e7ebc86
--- /dev/null
+++ b/drivers/alsa_midi/Makefile.am
@@ -0,0 +1,16 @@
+MAINTAINERCLEANFILES = Makefile.in
+
+#
+# slave driver to bridge to ALSA (sequencer) MIDI
+#
+
+driverdir = $(ADDON_DIR)
+
+driver_LTLIBRARIES = jack_alsa_midi.la
+
+jack_alsa_midi_la_LDFLAGS = -module -avoid-version @OS_LDFLAGS@
+jack_alsa_midi_la_SOURCES = alsa_midi.c port.c port_hash.c port_thread.c list.c
+jack_alsa_midi_la_LIBADD = $(ALSA_LIBS)
+
+noinst_HEADERS = a2j.h list.h port.h port_hash.h port_thread.h
+