summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..181ad4f
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,16 @@
+INCLUDES = -I$(top_srcdir)
+CFLAGS = @CFLAGS@ -std=gnu99
+
+h_sources = itzam.h
+
+cpp_sources = itzam_util.c itzam_data.c itzam_btree.c
+
+lib_LTLIBRARIES = libitzam.la
+
+libitzam_la_SOURCES = $(h_sources) $(cpp_sources)
+libitzam_la_LDFLAGS= -version-info $(GENERIC_LIBRARY_VERSION) -release $(GENERIC_RELEASE)
+
+library_includedir=$(includedir)/$(GENERIC_LIBRARY_NAME)
+library_include_HEADERS = $(h_sources)
+
+DEFS = -I. -I$(srcdir)