summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRyan Lortie <desrt@desrt.ca>2013-12-09 13:17:55 -0500
committerShaun McCance <shaunm@gnome.org>2013-12-11 12:09:19 -0500
commit1cce05f8c3d2b52f030b3e253d37ae5a6eee8003 (patch)
treec22618c5559c92cb92b47d96beef2caa2a953a9d /configure.ac
parent46067ed60cbe1e5e3efe176da1f40f8219336490 (diff)
downloaditstool-1cce05f8c3d2b52f030b3e253d37ae5a6eee8003.tar.gz
Don't hardcode python path
Instead, use automake to find it at runtime and put #!@PYTHON@ at the top of itstool.in. https://bugs.freedesktop.org/show_bug.cgi?id=72533
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c17d412..ef0180b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10,6 +10,8 @@ DATADIR=`(
)`
AC_SUBST([DATADIR])
+AM_PATH_PYTHON([2.6])
+
py_module=libxml2
AC_MSG_CHECKING(for python module $py_module)
echo "import $py_module" | python - &>/dev/null