summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorHuang Peng <shawn.p.huang@gmail.com>2008-06-29 15:57:07 +0800
committerHuang Peng <shawn.p.huang@gmail.com>2008-06-29 15:57:07 +0800
commit058ff8eec8aa8a7e5e8e7b404f2f47d87456bfaa (patch)
treeb44dc7e80ea33fc3b7a690925dd561a3ead76008 /Makefile.am
downloadibus-pinyin-058ff8eec8aa8a7e5e8e7b404f2f47d87456bfaa.tar.gz
Import IBus template project.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am52
1 files changed, 52 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..670d3f7
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,52 @@
+# vim:set noet ts=4:
+#
+# ibus - The Input Bus
+#
+# Copyright (c) 2007-2008 Huang Peng <shawn.p.huang@gmail.com>
+#
+# This library is free software; you can redistribute it and/or
+# modify it under the terms of the GNU Lesser General Public
+# License as published by the Free Software Foundation; either
+# version 2 of the License, or (at your option) any later version.
+#
+# This library is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU Lesser General Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public
+# License along with this program; if not, write to the
+# Free Software Foundation, Inc., 59 Temple Place, Suite 330,
+# Boston, MA 02111-1307 USA
+SUBDIRS = \
+ m4 \
+ po \
+ $(NULL)
+
+ACLOCAL_AMFLAGS = -I m4
+
+EXTRA_DIST = \
+ autogen.sh \
+ ibus-tmpl.spec.in \
+ $(NULL)
+
+noinst_DIST = \
+ $(NULL)
+
+
+DISTCLEANFILES = \
+ po/stamp-it \
+ $(NULL)
+
+rpm: dist ibus-tmpl.spec
+ rpmbuild -bb \
+ --define "_sourcedir `pwd`" \
+ --define "_builddir `pwd`" \
+ --define "_srcrpmdir `pwd`" \
+ --define "_rpmdir `pwd`" \
+ --define "_specdir `pwd`" \
+ @PACKAGE_NAME@.spec
+clean-rpm:
+ $(RM) -r "`uname -i`"
+
+clean-local: clean-rpm