summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorHuang Peng <shawn.p.huang@gmail.com>2008-06-29 15:57:07 +0800
committerHuang Peng <shawn.p.huang@gmail.com>2008-06-29 15:57:07 +0800
commit058ff8eec8aa8a7e5e8e7b404f2f47d87456bfaa (patch)
treeb44dc7e80ea33fc3b7a690925dd561a3ead76008 /configure.ac
downloadibus-hangul-058ff8eec8aa8a7e5e8e7b404f2f47d87456bfaa.tar.gz
Import IBus template project.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac69
1 files changed, 69 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..970ce27
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,69 @@
+# vim:set noet ts=4:
+#
+# ibus-tmpl - The Input Bus template project
+#
+# Copyright (c) 2007-2008 Huang Peng <shawn.p.huang@gmail.com>
+#
+# This library is free software; you can redistribute it and/or
+# modify it under the terms of the GNU Lesser General Public
+# License as published by the Free Software Foundation; either
+# version 2 of the License, or (at your option) any later version.
+#
+# This library is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU Lesser General Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public
+# License along with this program; if not, write to the
+# Free Software Foundation, Inc., 59 Temple Place, Suite 330,
+# Boston, MA 02111-1307 USA
+
+# if not 1, append datestamp to the version number.
+m4_define([ibus_released], [0])
+m4_define([ibus_major_version], [0])
+m4_define([ibus_minor_version], [1])
+m4_define([ibus_micro_version], [0])
+m4_define(ibus_maybe_datestamp,
+ m4_esyscmd([if test x]ibus_released[ != x1; then date +.%Y%m%d | tr -d '\n\r'; fi]))
+
+m4_define([ibus_version],
+ ibus_major_version.ibus_minor_version.ibus_micro_version[]ibus_maybe_datestamp)
+
+AC_INIT([ibus-tmpl], [ibus_version], [http://code.google.com/p/ibus/issues/entry],[ibus-tmpl])
+AM_INIT_AUTOMAKE([1.10])
+AC_GNU_SOURCE
+
+AC_CONFIG_HEADERS([config.h])
+AC_CONFIG_MACRO_DIR([m4])
+
+# define PACKAGE_VERSION_* variables
+AS_VERSION
+AS_NANO
+AM_SANITY_CHECK
+AM_MAINTAINER_MODE
+AM_DISABLE_STATIC
+AC_PROG_CC
+AM_PROG_CC_C_O
+AC_PROG_CXX
+AC_ISC_POSIX
+AC_HEADER_STDC
+AM_PROG_LIBTOOL
+
+# define GETTEXT_* variables
+GETTEXT_PACKAGE=ibus-tmpl
+AC_SUBST(GETTEXT_PACKAGE)
+AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE,"$GETTEXT_PACKAGE", [Define to the read-only architecture-independent data directory.])
+
+AM_GNU_GETTEXT([external])
+AM_GNU_GETTEXT_VERSION(0.16.1)
+
+
+# OUTPUT files
+AC_CONFIG_FILES([ po/Makefile.in
+Makefile
+ibus-tmpl.spec
+m4/Makefile
+])
+
+AC_OUTPUT