summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 19ab982..9a06d68 100644
--- a/configure.ac
+++ b/configure.ac
@@ -360,6 +360,17 @@ else
AC_MSG_ERROR([ibus 1.5 or later supports layout_option in IBus.EngineDesc])
fi
+AC_MSG_CHECKING([if IBus.EngineDesc has get_version])
+DESC_VERSION_TEST="from gi.repository import IBus
+exit(not hasattr(IBus.EngineDesc, 'get_version'))
+"
+$PYTHON -c "$DESC_VERSION_TEST"
+if test $? -eq 0; then
+ AC_MSG_RESULT([yes])
+else
+ AC_MSG_ERROR([ibus 1.5 or later supports version in IBus.EngineDesc])
+fi
+
dnl - set ibus-anthy layout
AC_ARG_WITH(layout,
[AC_HELP_STRING([--with-layout=LAYOUT],