summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorfujiwarat <takao.fujiwara1@gmail.com>2012-12-31 00:31:50 +0900
committerfujiwarat <takao.fujiwara1@gmail.com>2012-12-31 00:31:50 +0900
commitccc32ee73eb600bb1aabe60eafe7696c5ea1a16d (patch)
treee737cf7ad8043f9abbd6a171935258bca31b8fc9 /configure.ac
parent83d02bc6ce75e3f76eceffd2b0f234bde34e6a14 (diff)
downloadibus-anthy-ccc32ee73eb600bb1aabe60eafe7696c5ea1a16d.tar.gz
Added to sync the user config xml between versions.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 19ab982..9a06d68 100644
--- a/configure.ac
+++ b/configure.ac
@@ -360,6 +360,17 @@ else
AC_MSG_ERROR([ibus 1.5 or later supports layout_option in IBus.EngineDesc])
fi
+AC_MSG_CHECKING([if IBus.EngineDesc has get_version])
+DESC_VERSION_TEST="from gi.repository import IBus
+exit(not hasattr(IBus.EngineDesc, 'get_version'))
+"
+$PYTHON -c "$DESC_VERSION_TEST"
+if test $? -eq 0; then
+ AC_MSG_RESULT([yes])
+else
+ AC_MSG_ERROR([ibus 1.5 or later supports version in IBus.EngineDesc])
+fi
+
dnl - set ibus-anthy layout
AC_ARG_WITH(layout,
[AC_HELP_STRING([--with-layout=LAYOUT],