summaryrefslogtreecommitdiff
path: root/setup/Makefile.am
diff options
context:
space:
mode:
authorfujiwarat <takao.fujiwara1@gmail.com>2012-03-05 14:03:34 +0900
committerfujiwarat <takao.fujiwara1@gmail.com>2012-03-05 14:03:34 +0900
commit5ecd67f59c8aa8993dc6eb9afeb66c330b1eb8c8 (patch)
treefc64210b81701f5b8c30608692c01c9c73c39883 /setup/Makefile.am
parent85e1b094985d6f8f61d324f45cf893c7c63c38b5 (diff)
downloadibus-anthy-5ecd67f59c8aa8993dc6eb9afeb66c330b1eb8c8.tar.gz
Converted pygtk2 to gir gtk3.
Diffstat (limited to 'setup/Makefile.am')
-rw-r--r--setup/Makefile.am17
1 files changed, 15 insertions, 2 deletions
diff --git a/setup/Makefile.am b/setup/Makefile.am
index b59b58a..6fcec7b 100644
--- a/setup/Makefile.am
+++ b/setup/Makefile.am
@@ -20,15 +20,19 @@
# along with this program; if not, write to the Free Software
# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
-BUILT_SOURCES = anthyprefs.py
+BUILT_SOURCES = \
+ _config.py \
+ anthyprefs.py \
+ $(NULL)
libexec_SCRIPTS = ibus-setup-anthy
setup_anthy_PYTHON = \
+ _config.py \
anthyprefs.py \
main.py \
prefs.py \
- setup.glade \
+ setup.ui \
$(NULL)
setup_anthy_built_files = \
@@ -62,6 +66,15 @@ anthyprefs.py: anthyprefs.py.in
-e "s|\@pkgdatadir\@|$(pkgdatadir)|g" \
$< > $@
+_config.py: _config.py.in
+ ( \
+ PKGDATADIR=$(pkgdatadir); \
+ LIBEXECDIR=$(libexecdir); \
+ DATADIR=$(datadir); \
+ s=`cat $<`; \
+ eval "echo \"$${s}\""; \
+ ) > $@
+
# Need a time lag between .py and .py.in files to build .py files
# because *_PYTHON valuables are installed in the tarball.
dist-hook: