summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorfujiwarat <takao.fujiwara1@gmail.com>2015-06-26 17:51:35 +0900
committerfujiwarat <takao.fujiwara1@gmail.com>2015-06-26 17:51:35 +0900
commitb0249f499e3ff264d3b7c5ca43fba86a21b0084d (patch)
tree5032f8fbc1bc00809da1f3776bb485ffdc6a1a01 /configure.ac
parent107f08343063275a84ce370e4c40bf222507ba4c (diff)
downloadibus-anthy-b0249f499e3ff264d3b7c5ca43fba86a21b0084d.tar.gz
Added icon_prop_key in default.xml
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 64139a4..bc1d858 100644
--- a/configure.ac
+++ b/configure.ac
@@ -366,6 +366,21 @@ else
AC_MSG_ERROR([ibus 1.5 or later supports version in IBus.EngineDesc])
fi
+dnl - check icon_prop_key in IBus.EngineDesc
+AC_MSG_CHECKING([if IBus.EngineDesc has get_icon_prop_key])
+ICON_PROP_KEY_TEST="from gi.repository import IBus
+exit(not hasattr(IBus.EngineDesc, 'get_icon_prop_key'))
+"
+$PYTHON -c "$ICON_PROP_KEY_TEST"
+if test $? -eq 0; then
+ ICON_PROP_KEY_XML="<icon_prop_key>InputMode</icon_prop_key>"
+ AC_MSG_RESULT([yes])
+else
+ ICON_PROP_KEY_XML="<!-- <icon_prop_key>InputMode</icon_prop_key> -->"
+ AC_MSG_RESULT([ibus 1.5.11 or later supports icon-prop-key in IBus.EngineDesc])
+fi
+AC_SUBST(ICON_PROP_KEY_XML)
+
dnl - set ibus-anthy layout
AC_ARG_WITH(layout,
[AC_HELP_STRING([--with-layout=LAYOUT],
@@ -452,5 +467,6 @@ ICON_PREFERENCE $ICON_PREFERENCE
ON_OFF_KEYS $ON_OFF_KEYS
HOTKEYS_XML $HOTKEYS_XML
SYMBOL_XML $SYMBOL_XML
+ICON_PROP_KEY_XML $ICON_PROP_KEY_XML
LAYOUT_XML $LAYOUT_XML
"