summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorfujiwarat <takao.fujiwara1@gmail.com>2012-10-05 21:24:54 +0900
committerfujiwarat <takao.fujiwara1@gmail.com>2012-10-05 21:24:54 +0900
commitacaaa1578cbff50806bbd977e42b37f6358b0734 (patch)
tree402ac6b6e446d4e785a72e19e695b7f9a802db08 /configure.ac
parent70dc912db827c333995c09e06dda88ab076e792d (diff)
downloadibus-anthy-acaaa1578cbff50806bbd977e42b37f6358b0734.tar.gz
Added keyboard layout customization.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 6 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 10586b3..e0f49c2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -308,6 +308,7 @@ AC_SUBST(HOTKEYS_XML)
dnl - check symbol in IBus.EngineDesc
AC_MSG_CHECKING([if IBus.EngineDesc has get_symbol])
SYMBOL_CHAR='&#x3042;'
+SYMBOL_CHAR_INT=0x3042
SYMBOL_TEST="from gi.repository import IBus
exit(not hasattr(IBus.EngineDesc, 'get_symbol'))
"
@@ -319,6 +320,7 @@ else
SYMBOL_XML="<!-- <symbol>${SYMBOL_CHAR}</symbol> -->"
AC_MSG_ERROR([ibus 1.4 or later supports symbol in IBus.EngineDesc])
fi
+AC_SUBST(SYMBOL_CHAR_INT)
AC_SUBST(SYMBOL_XML)
dnl - check symbol in IBus.Property
@@ -341,10 +343,10 @@ AC_ARG_WITH(layout,
[LAYOUT="$withval"],
[LAYOUT="jp"])
if test x"$LAYOUT" = x; then
- LAYOUT_XML="<layout>jp</layout>"
-else
- LAYOUT_XML="<layout>${LAYOUT}</layout>"
+ LAYOUT="jp"
fi
+LAYOUT_XML="<layout>${LAYOUT}</layout>"
+AC_SUBST(LAYOUT)
AC_SUBST(LAYOUT_XML)
dnl libtool versioning
@@ -379,6 +381,7 @@ gir/Makefile
engine/Makefile
engine/ibus-engine-anthy
engine/anthy.xml.in
+engine/default.xml.in
setup/Makefile
setup/ibus-setup-anthy
icons/Makefile