summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorfujiwarat <takao.fujiwara1@gmail.com>2012-09-14 11:40:57 +0900
committerfujiwarat <takao.fujiwara1@gmail.com>2012-09-14 11:40:57 +0900
commit7f5a9dc9942b52381d6ab7b4f6c9009057a2c759 (patch)
tree81b32f2c52e50ed90c6d0300209fb029e55e2dbe /configure.ac
parent82dd7dd6c1511002296c3b9d4d8487e22eb0700d (diff)
downloadibus-anthy-7f5a9dc9942b52381d6ab7b4f6c9009057a2c759.tar.gz
Enabled IBusProperty.symbol with ibus 1.5 .
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 17 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index a6dddab..10586b3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -305,19 +305,34 @@ else
fi
AC_SUBST(HOTKEYS_XML)
+dnl - check symbol in IBus.EngineDesc
+AC_MSG_CHECKING([if IBus.EngineDesc has get_symbol])
SYMBOL_CHAR='&#x3042;'
SYMBOL_TEST="from gi.repository import IBus
-engine = IBus.EngineDesc(name='test')
-exit(not hasattr(engine, 'get_symbol'))
+exit(not hasattr(IBus.EngineDesc, 'get_symbol'))
"
$PYTHON -c "$SYMBOL_TEST"
if test $? -eq 0; then
SYMBOL_XML="<symbol>${SYMBOL_CHAR}</symbol>"
+ AC_MSG_RESULT([yes])
else
SYMBOL_XML="<!-- <symbol>${SYMBOL_CHAR}</symbol> -->"
+ AC_MSG_ERROR([ibus 1.4 or later supports symbol in IBus.EngineDesc])
fi
AC_SUBST(SYMBOL_XML)
+dnl - check symbol in IBus.Property
+AC_MSG_CHECKING([if IBus.Property has get_symbol])
+SYMBOL_TEST="from gi.repository import IBus
+exit(not hasattr(IBus.Property, 'get_symbol'))
+"
+$PYTHON -c "$SYMBOL_TEST"
+if test $? -eq 0; then
+ AC_MSG_RESULT([yes])
+else
+ AC_MSG_ERROR([ibus 1.5 or later supports symbol in IBus.Property])
+fi
+
dnl - set ibus-anthy layout
AC_ARG_WITH(layout,
[AC_HELP_STRING([--with-layout=LAYOUT],