summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorfujiwarat <takao.fujiwara1@gmail.com>2019-10-16 17:58:55 +0900
committerfujiwarat <takao.fujiwara1@gmail.com>2019-10-16 17:58:55 +0900
commit5a9e4858f1a2b6cad02ef1d272fc5bed959ec0bf (patch)
tree04b65b01bef4bc9d3000fcb9d78c7dcc4946c80e /configure.ac
parentbb6349428de332faae90ed54322d1a341ae6f978 (diff)
downloadibus-anthy-5a9e4858f1a2b6cad02ef1d272fc5bed959ec0bf.tar.gz
Integrate anthy automation tests to ibus-desktop-testing-runner
The test cases can be run with ibus-desktop-testing-runner: % ibus-desktop-testing-runner \ --no-graphics \ --runner=gnome \ --tests='ibus-anthy' \ --output='./ibus-anthy.log' \ --result='./test.log' ibus-desktop-testing-runner requires gnome-desktop-testing-runner in case --runner option is given.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 06c4521..64afcc6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -398,6 +398,20 @@ LAYOUT_XML="<layout>${LAYOUT}</layout>"
AC_SUBST(LAYOUT)
AC_SUBST(LAYOUT_XML)
+dnl --enable-installed-tests
+AC_ARG_ENABLE(installed-tests,
+ AS_HELP_STRING([--enable-installed-tests],
+ [Enable to installed tests]),
+ [enable_installed_tests=$enableval],
+ [enable_installed_tests=no]
+)
+AM_CONDITIONAL([ENABLE_INSTALLED_TESTS],
+ [test x"$enable_installed_tests" = x"yes"])
+if test x"$enable_installed_tests" = x"no"; then
+ enable_installed_tests="no (disabled, use --enable-installed-tests to enable)"
+fi
+
+
dnl libtool versioning
dnl
dnl If LT_VERSION_INFO="lt_current:lt_revision:lt_age", libibus is