summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorfujiwarat <takao.fujiwara1@gmail.com>2012-10-19 17:41:56 +0900
committerfujiwarat <takao.fujiwara1@gmail.com>2012-10-19 17:41:56 +0900
commit3800c47df3c2a7306f37589647d67220f8426524 (patch)
tree76f77bb0bf39096c9fc679a5675f08ba1b6dc45a /configure.ac
parent1765e872691080d8dc6f3f7997443c84aa629fe9 (diff)
downloadibus-anthy-3800c47df3c2a7306f37589647d67220f8426524.tar.gz
Added xkb options with ibus 1.5.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e0f49c2..5dab38f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -335,6 +335,18 @@ else
AC_MSG_ERROR([ibus 1.5 or later supports symbol in IBus.Property])
fi
+dnl - check XKB option in IBus.EngineDesc
+AC_MSG_CHECKING([if IBus.EngineDesc has get_layout_option])
+LAYOUT_OPTION_TEST="from gi.repository import IBus
+exit(not hasattr(IBus.EngineDesc, 'get_layout_option'))
+"
+$PYTHON -c "$LAYOUT_OPTION_TEST"
+if test $? -eq 0; then
+ AC_MSG_RESULT([yes])
+else
+ AC_MSG_ERROR([ibus 1.5 or later supports layout_option in IBus.EngineDesc])
+fi
+
dnl - set ibus-anthy layout
AC_ARG_WITH(layout,
[AC_HELP_STRING([--with-layout=LAYOUT],