summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/README4
-rw-r--r--debian/control18
-rw-r--r--debian/copyright18
-rw-r--r--debian/docs1
-rw-r--r--debian/examples1
-rwxr-xr-xdebian/rules93
6 files changed, 135 insertions, 0 deletions
diff --git a/debian/README b/debian/README
new file mode 100644
index 0000000..b7afaea
--- /dev/null
+++ b/debian/README
@@ -0,0 +1,4 @@
+An example --include file. This is used to create help2man's own man
+page:
+
+ $ help2man --include=help2man.h2m help2man
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..1c9714c
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,18 @@
+Source: help2man
+Section: devel
+Priority: optional
+Maintainer: Brendan O'Dea <bod@debian.org>
+Standards-Version: 3.5.1
+Build-Depends: perl (>= 5.6.0-18), debhelper (>= 3.0.5), gettext, liblocale-gettext-perl
+
+Package: help2man
+Architecture: all
+Depends: ${perl:Depends}
+Recommends: gettext, liblocale-gettext-perl
+Description: Automatic manpage generator
+ Program to create simple man pages from the --help and
+ --version output of other programs.
+ .
+ Since most GNU documentation is now in info format, this provides a
+ way to generate a placeholder man page pointing to that resource while
+ still providing some useful information.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..8b87c8c
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,18 @@
+Copyright (C) 1997, 1998, 1999, 2000, 2001, 2002, 2003 Free Software
+Foundation, Inc.
+
+This is free software; see the source for copying conditions. There is NO
+warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
+
+Written by Brendan O'Dea <bod@debian.org>
+
+help2man is licenced under the terms of the GNU General Public License (GPL)
+version 2 or later, as published by the Free Software Foundation.
+
+On Debian GNU/Linux systems, the text of the GPL can be found in
+/usr/share/common-licenses/GPL.
+
+It may be downloaded from:
+
+ http://packages.debian.org/unstable/devel/help2man.html or
+ ftp://ftp.gnu.org/gnu/help2man/
diff --git a/debian/docs b/debian/docs
new file mode 100644
index 0000000..7f879e1
--- /dev/null
+++ b/debian/docs
@@ -0,0 +1 @@
+NEWS README THANKS
diff --git a/debian/examples b/debian/examples
new file mode 100644
index 0000000..563acea
--- /dev/null
+++ b/debian/examples
@@ -0,0 +1 @@
+debian/README help2man.h2m
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..d5acbbf
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,93 @@
+#!/usr/bin/make -f
+#-*- makefile -*-
+# Made with the aid of dh_make, by Craig Small
+# Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
+# Some lines taken from debmake, by Christoph Lameter.
+
+SHELL=/bin/bash
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+build: build-stamp
+build-stamp:
+ dh_testdir
+ ./configure --prefix=/usr --mandir='$${prefix}/share/man' \
+ --infodir='$${prefix}/share/info'
+
+ $(MAKE)
+ touch build-stamp
+
+clean:
+ test README -nt help2man.PL # maintainer sanity check
+ dh_testdir
+ dh_testroot
+ -$(MAKE) distclean
+ rm -f build-stamp install-stamp
+ dh_clean
+
+install: install-stamp
+install-stamp: build-stamp
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+ $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
+ touch install-stamp
+
+# Build architecture-independent files here.
+binary-indep: build install
+ dh_testdir
+ dh_testroot
+ dh_installdocs
+ dh_installinfo
+ dh_installexamples
+ dh_installchangelogs
+ dh_compress
+ dh_fixperms
+ dh_installdeb
+ dh_perl -V
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+# Build architecture-dependent files here.
+binary-arch: build install
+# We have nothing to do by default.
+
+source diff:
+ @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
+
+# maintainer pre-release setup
+AM = COPYING INSTALL install-sh mkinstalldirs
+maint-prep:
+ cp $(addprefix /usr/share/automake/,$(AM)) .
+ export ver=`./help2man.PL --version`; \
+ export debver=`perl -ne '/[^(]*\(([^)]*)/ and print $1; exit' debian/changelog`; \
+ (echo " README for GNU help2man version $$ver"; \
+ echo; \
+ echo "help2man is a script to create simple man pages from the --help and"; \
+ echo "--version output of programs."; \
+ echo ""; \
+ echo " http://www.gnu.org/software/help2man/"; \
+ echo " ftp://ftp.gnu.org/gnu/help2man/help2man-$$debver.tar.gz"; \
+ echo ""; \
+ echo "Since most GNU documentation is now in info format, this provides a"; \
+ echo "way to generate a placeholder man page pointing to that resource while"; \
+ echo "still providing some useful information."; \
+ echo ""; \
+ echo "-- "; \
+ echo "Brendan O'Dea <bod@debian.org>") >README
+ ln -sf debian/changelog ChangeLog
+ autoconf
+ configure
+ $(MAKE) all distclean
+
+maint-clean: maint-prep
+ configure
+ $(MAKE) maintainer-clean
+ rm -f README ChangeLog $(AM)
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary maint-prep maint-clean