summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 8 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index c4fdf8b..44584ea 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,6 +1,6 @@
dnl Process this file with autoconf to produce a configure script.
-# Copyright (C) 2012 Free Software Foundation, Inc.
+# Copyright (C) 2012, 2014 Free Software Foundation, Inc.
# Copying and distribution of this file, with or without modification,
# are permitted in any medium without royalty provided the copyright
@@ -12,12 +12,12 @@ dnl Written by Brendan O'Dea <bod@debian.org>
AC_INIT([GNU help2man], m4_esyscmd_s([./help2man.PL --version]),
[bug-help2man@gnu.org])
-AC_CONFIG_SRCDIR([help2man.PL])
+AC_CONFIG_SRCDIR(help2man.PL)
-AC_PROG_PERL(5.008)
+LOCAL_PROG_PERL(5.008)
test -z "$PERL" && AC_MSG_ERROR([perl 5.8 required])
-AC_PERL_MODULE(Locale::gettext)
+LOCAL_PERL_MODULE(Locale::gettext)
AC_PATH_PROG(MSGFMT, msgfmt)
AC_PROG_CC
@@ -57,8 +57,10 @@ then
fi
AC_PROG_INSTALL
-AC_PATH_PROG(MAKEINFO, makeinfo, :)
-AC_PATH_PROG(INSTALL_INFO, install-info, :)
+LOCAL_PROG_OR_MISSING(makeinfo)
+LOCAL_PROG_OR_MISSING(install-info)
+LOCAL_PROG_OR_MISSING(msgmerge)
+LOCAL_PROG_OR_MISSING(xgettext)
AC_CONFIG_FILES([Makefile])
AC_OUTPUT