summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorBrendan O'Dea <bod@debian.org>2021-03-03 13:50:04 +1100
committerBrendan O'Dea <bod@debian.org>2021-03-03 13:50:04 +1100
commitc8e2339fbe080d0445b86afc73cf9671e9451574 (patch)
treecfd7eb3a1b0c6fdd24bba2de1b7258c05079a1c5 /debian
parent1aeb5736abe3ef2fe0c1ce7d29df3802b53eecb6 (diff)
downloadhelp2man-c8e2339fbe080d0445b86afc73cf9671e9451574.tar.gz
Use debhelper dh command sequencer
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog6
-rwxr-xr-xdebian/rules71
2 files changed, 20 insertions, 57 deletions
diff --git a/debian/changelog b/debian/changelog
index 688c021..690b541 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+help2man (1.48.2) unstable; urgency=medium
+
+ * Use debhelper dh command sequencer.
+
+ -- Brendan O'Dea <bod@debian.org> Wed, 03 Mar 2021 12:19:58 +1100
+
help2man (1.48.1) unstable; urgency=medium
* Update German, Spanish, Norwegian Bokmaal, Polish, Brazilian
diff --git a/debian/rules b/debian/rules
index 134ecf3..dbb4a73 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,7 +2,7 @@
# Debian build rules for help2man.
-# Copyright (C) 2012, 2014, 2017, 2018 Free Software Foundation, Inc.
+# Copyright (C) 2012, 2014, 2017, 2018, 2021 Free Software Foundation, Inc.
# Copying and distribution of this file, with or without modification,
# are permitted in any medium without royalty provided the copyright
@@ -12,65 +12,22 @@
# Written by Brendan O'Dea <bod@debian.org>
SHELL = /bin/bash
-DPKG_EXPORT_BUILDFLAGS = 1
-export DEB_BUILD_MAINT_OPTIONS=hardening=+all
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
-include /usr/share/dpkg/architecture.mk
-include /usr/share/dpkg/buildflags.mk
-include /usr/share/dpkg/pkg-info.mk
+%:
+ dh $@
-ifneq ($(DEB_BUILD_GNU_TYPE),$(DEB_HOST_GNU_TYPE))
- CONFARGS = --host=$(DEB_HOST_GNU_TYPE)
-endif
+execute_before_dh_clean: check-maint-prep # maintainer sanity check
-build: build-arch build-indep
-build-arch build-indep: build-stamp
-build-stamp:
- dh_testdir
- dh_update_autotools_config # update config.guess, config.sub
- ./configure --prefix=/usr --enable-nls --mandir='$${prefix}/share/man' \
- --infodir='$${prefix}/share/info' $(CONFARGS)
+override_dh_auto_configure:
+ dh_auto_configure -- --libdir=\$$\{prefix\}/lib # omit arch from libdir
- $(MAKE)
+execute_after_dh_auto_build:
$(MAKE) help2man.h2m # for examples
- touch build-stamp
-clean: check-maint-prep # maintainer sanity check
- dh_testdir
- dh_testroot
- [ ! -f Makefile ] || $(MAKE) distclean
- rm -f build-stamp install-stamp
- dh_clean
-
-install: install-stamp
-install-stamp: build-stamp
- dh_testdir
- dh_testroot
- dh_prep
- dh_installdirs
- $(MAKE) install DESTDIR=$(CURDIR)/debian/help2man
- touch install-stamp
-
-binary: binary-indep binary-arch
-binary-arch: build install
- dh_testdir
- dh_testroot
- dh_installdocs
- dh_installinfo
- dh_installexamples
- dh_installchangelogs
- dh_strip
- dh_compress
- dh_fixperms
- dh_perl -V
- dh_installdeb
- dh_shlibdeps
- dh_gencontrol
- dh_md5sums
- dh_builddeb
-
-binary-indep: build install
+.PHONY: execute_before_dh_clean override_dh_auto_configure
+.PHONY: execute_after_dh_auto_build
# Maintainer pre-release setup. Intended to be run from a copy of the
# contents of the git repository, excluding the .git subdir. E.g. something
@@ -88,6 +45,7 @@ AM_DOC = COPYING INSTALL
AM_AUX = install-sh missing mkinstalldirs
AM_DIR = $(shell ls -d /usr/share/automake* 2>/dev/null | tail -1)
PKG_VERSION = $(shell ./help2man.PL --version)
+include /usr/share/dpkg/pkg-info.mk # DEB_VERSION
maint-prep:
test -n $(AM_DIR)
test $(DEB_VERSION) = $(PKG_VERSION) # mismatch b/w $$version in help2man.PL and changelog
@@ -114,8 +72,8 @@ maint-prep:
./configure
$(MAKE) update-po all distclean
-# Simple sanity check that the above rule has been run prior to release (a
-# dependency of the "clean" rule, which is the first thing run when building a
+# Simple sanity check that the above rule has been run prior to release (run
+# as part of the "clean" rule, which is the first thing run when building a
# debian package).
check-maint-prep:
test -x configure # autoconf has been run
@@ -127,5 +85,4 @@ maint-clean: maint-prep
$(MAKE) maintainer-clean
rm -f README ChangeLog $(AM_DOC) $(addprefix build-aux/,$(AM_AUX))
-.PHONY: build build-arch build-indep clean install binary binary-arch
-.PHONY: binary-indep maint-prep check-maint-prep maint-clean
+.PHONY: maint-prep check-maint-prep maint-clean