summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorBrendan O'Dea <bod@debian.org>2014-07-26 14:21:55 +1000
committerBrendan O'Dea <bod@debian.org>2014-07-26 14:21:55 +1000
commitb4cbd8cd6e742fee1f3f5ca25a734756b1bfe0be (patch)
treec48382bebc5a07a112904af9879e54e881086769 /debian
parent23c84e7a9f8fbe4b699e8cd50887e4c3670ba67d (diff)
downloadhelp2man-b4cbd8cd6e742fee1f3f5ca25a734756b1bfe0be.tar.gz
Move automake helper scripts to build-aux dir
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog3
-rwxr-xr-xdebian/rules8
2 files changed, 7 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index 0c6496c..d2e4285 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -18,8 +18,9 @@ help2man (1.45.2) unstable; urgency=medium
* Add Hungarian translation (thanks to Balázs Úr).
* Update Polish translation, and add translation of info page (thanks to
Jakub Bogusz).
+ * Move automake helper scripts into a build-aux sub-directory.
- -- Brendan O'Dea <bod@debian.org> Sun, 20 Jul 2014 22:01:34 +1000
+ -- Brendan O'Dea <bod@debian.org> Sat, 26 Jul 2014 14:21:18 +1000
help2man (1.45.1) unstable; urgency=low
diff --git a/debian/rules b/debian/rules
index ef470d3..b11d1d9 100755
--- a/debian/rules
+++ b/debian/rules
@@ -73,13 +73,15 @@ source diff:
@echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
# maintainer pre-release setup
-AM = COPYING INSTALL install-sh missing mkinstalldirs
+AM_DOC = COPYING INSTALL
+AM_AUX = install-sh missing mkinstalldirs
AM_DIR = $(shell ls -d /usr/share/automake* 2>/dev/null | tail -1)
VERSION = $(shell ./help2man.PL --version)
maint-prep:
test -n $(AM_DIR)
test `dpkg-parsechangelog | sed -n 's/^Version:\s\+//p'` = $(VERSION)
- cp $(addprefix $(AM_DIR)/,$(AM)) .
+ cp $(addprefix $(AM_DIR)/,$(AM_DOC)) .
+ cp $(addprefix $(AM_DIR)/,$(AM_AUX)) build-aux
(echo " README for GNU help2man version $(VERSION)"; \
echo; \
echo "help2man is a script to create simple man pages from the --help and"; \
@@ -105,7 +107,7 @@ maint-prep:
maint-clean: maint-prep
./configure
$(MAKE) maintainer-clean
- rm -f README ChangeLog $(AM)
+ rm -f README ChangeLog $(AM_DOC) $(addprefix build-aux/,$(AM_AUX))
binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary maint-prep maint-clean