summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorBrendan O'Dea <bod@debian.org>2019-03-23 12:19:46 +1100
committerBrendan O'Dea <bod@debian.org>2019-03-23 12:19:46 +1100
commit757e6437a9a88648f3eebb5082ffb03482d870f1 (patch)
tree1035d0a95d1faecbd264768e6425547e173bc2af /debian
parent7e841b63fc069906f351b301560195aaa377fe7a (diff)
downloadhelp2man-757e6437a9a88648f3eebb5082ffb03482d870f1.tar.gz
Fix maintainer sanity check to handle changes to dpkg-sourcev1.47.10
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog8
-rwxr-xr-xdebian/rules12
2 files changed, 17 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 55341cc..74232a3 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+help2man (1.47.10) unstable; urgency=medium
+
+ * Change maintainer sanity check in debian/rules to use the contents
+ of README rather than the mtime, which may be have been modified by
+ dpkg-source (closes: #925136).
+
+ -- Brendan O'Dea <bod@debian.org> Sat, 23 Mar 2019 12:18:57 +1100
+
help2man (1.47.9) unstable; urgency=medium
* Add Tamil translation (thanks to Arun Isaac).
diff --git a/debian/rules b/debian/rules
index b615bf9..d07af1d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -36,8 +36,7 @@ build-stamp:
$(MAKE) help2man.h2m # for examples
touch build-stamp
-clean:
- test README -nt help2man.PL # maintainer sanity check
+clean: check-maint-prep # maintainer sanity check
dh_testdir
dh_testroot
[ ! -f Makefile ] || $(MAKE) distclean
@@ -115,10 +114,17 @@ maint-prep:
./configure
$(MAKE) update-po all distclean
+# Simple sanity check that the above rule has been run prior to release (a
+# dependency of the "clean" rule, which is the first thing run when building a
+# debian package).
+check-maint-prep:
+ test -x configure # autoconf has been run
+ grep -qF 'help2man-$(DEB_VERSION).tar' README # exists and up to date
+
maint-clean: maint-prep
./configure
$(MAKE) maintainer-clean
rm -f README ChangeLog $(AM_DOC) $(addprefix build-aux/,$(AM_AUX))
.PHONY: build build-arch build-indep clean install binary binary-arch
-.PHONY: binary-indep maint-prep maint-clean
+.PHONY: binary-indep maint-prep check-maint-prep maint-clean