summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorBrendan O'Dea <bod@debian.org>2018-10-13 13:44:11 +1100
committerBrendan O'Dea <bod@debian.org>2018-10-13 13:44:11 +1100
commit11466973cf9a29d41c88d6791c990a9958011d1c (patch)
tree0ed33bf5171f3d78dee36725c87ba1a26ce8edff /debian/rules
parent0e262cb74da79c66941775a52756e988e139f722 (diff)
downloadhelp2man-11466973cf9a29d41c88d6791c990a9958011d1c.tar.gz
Use $(DEB_VERSION) from pkg-info.mk
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules9
1 files changed, 5 insertions, 4 deletions
diff --git a/debian/rules b/debian/rules
index a9a3f9a..cd0385f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -18,6 +18,7 @@ export DEB_BUILD_MAINT_OPTIONS=hardening=+all
include /usr/share/dpkg/architecture.mk
include /usr/share/dpkg/buildflags.mk
+include /usr/share/dpkg/pkg-info.mk
ifneq ($(DEB_BUILD_GNU_TYPE),$(DEB_HOST_GNU_TYPE))
CONFARGS = --host=$(DEB_HOST_GNU_TYPE)
@@ -81,19 +82,19 @@ source diff:
AM_DOC = COPYING INSTALL
AM_AUX = install-sh missing mkinstalldirs
AM_DIR = $(shell ls -d /usr/share/automake* 2>/dev/null | tail -1)
-VERSION = $(shell ./help2man.PL --version)
+PKG_VERSION = $(shell ./help2man.PL --version)
maint-prep:
test -n $(AM_DIR)
- test `dpkg-parsechangelog --show-field=Version` = $(VERSION)
+ test $(DEB_VERSION) = $(PKG_VERSION)
cp $(addprefix $(AM_DIR)/,$(AM_DOC)) .
cp $(addprefix $(AM_DIR)/,$(AM_AUX)) build-aux
- (echo " README for GNU help2man version $(VERSION)"; \
+ (echo " README for GNU help2man version $(PKG_VERSION)"; \
echo; \
echo "help2man is a script to create simple man pages from the --help and"; \
echo "--version output of programs."; \
echo ""; \
echo " http://www.gnu.org/software/help2man/"; \
- echo " ftp://ftp.gnu.org/gnu/help2man/help2man-$(VERSION).tar.xz"; \
+ echo " ftp://ftp.gnu.org/gnu/help2man/help2man-$(PKG_VERSION).tar.xz"; \
echo ""; \
echo " git://anonscm.debian.org/users/bod/help2man.git"; \
echo " http://anonscm.debian.org/gitweb/?p=users/bod/help2man.git"; \