summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSimon Marlow <simonmar@microsoft.com>2006-11-20 14:36:57 +0000
committerSimon Marlow <simonmar@microsoft.com>2006-11-20 14:36:57 +0000
commite4e7b37c7ed6b2cd39c34c30f7dcf9369a562496 (patch)
tree0b3807ba6859220a53ba9e00823041d094dc855e /configure.ac
parentbed7074cda231f30aec19e5c69785719d770aca4 (diff)
downloadhaskell-e4e7b37c7ed6b2cd39c34c30f7dcf9369a562496.tar.gz
reorganise PAPI configuration: off by default, even if library is found
Add GhcRtsWithPapi=YES to mk/build.mk to turn it on
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index a4a229c6c8..f1e5fa2fe5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1207,9 +1207,11 @@ AC_SUBST(HavePapiLib)
AC_SUBST(HavePapiHeader)
if test "$HavePapiLib" = "YES" -a "$HavePapiHeader" = "YES"; then
- USE_PAPI=YES
+ HavePapi=YES
+else
+ HavePapi=NO
fi
-AC_SUBST(USE_PAPI)
+AC_SUBST(HavePapi)
AC_CONFIG_FILES([mk/config.mk ghc.spec docs/users_guide/ug-book.xml])
AC_CONFIG_COMMANDS([mk/stamp-h],[echo timestamp > mk/stamp-h])