summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPHO <pho@cielonegro.org>2022-02-08 13:08:03 +0900
committerMarge Bot <ben+marge-bot@smart-cactus.org>2022-02-08 10:43:19 -0500
commitbd493ed6a63e41855f90c210f6cf1bace9199cf0 (patch)
treee8d5c298c84e5b0931da11a3210373bbe93335a7 /configure.ac
parentb33f0cfabfcace98bb8b77a5bce6c6efba076cf6 (diff)
downloadhaskell-bd493ed6a63e41855f90c210f6cf1bace9199cf0.tar.gz
Don't try to build stage1 with -eventlog if stage0 doesn't provide it
Like -threaded, stage0 isn't guaranteed to have an event-logging RTS.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index cb670a2a14..cf3d586590 100644
--- a/configure.ac
+++ b/configure.ac
@@ -212,13 +212,21 @@ if test "$WithGhc" != ""; then
dnl See Note [Linking ghc-bin against threaded stage0 RTS] in
dnl hadrian/src/Settings/Packages.hs for details.
dnl SMP support which implies a registerised stage0 is also required (see issue 18266)
- if echo ${RTS_WAYS_STAGE0} | grep '.*thr.*' 2>&1 >/dev/null && \
+ if echo ${RTS_WAYS_STAGE0} | tr ' ' '\n' | grep '^thr$' 2>&1 >/dev/null && \
test "$SUPPORT_SMP_STAGE0" = "YES"
then
AC_SUBST(GhcThreadedRts, YES)
else
AC_SUBST(GhcThreadedRts, NO)
fi
+
+ dnl Same for an event-logging RTS.
+ if echo ${RTS_WAYS_STAGE0} | tr ' ' '\n' | grep '^l$' 2>&1 >/dev/null
+ then
+ AC_SUBST(GhcEventLoggingRts, YES)
+ else
+ AC_SUBST(GhcEventLoggingRts, NO)
+ fi
fi
dnl ** Must have GHC to build GHC
@@ -1364,6 +1372,7 @@ echo "\
Bootstrapping using : $WithGhc
which is version : $GhcVersion
with threaded RTS? : $GhcThreadedRts
+ with eventlog RTS? : $GhcEventLoggingRts
"
if test "x$CcLlvmBackend" = "xYES"; then