summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <meyering@fb.com>2016-03-06 12:27:28 -0800
committerJim Meyering <meyering@fb.com>2016-03-06 12:27:28 -0800
commitef80dc4ff003105071a6ba7470b30f4ba57e6e8a (patch)
tree63fdeb9cc21ceb2ede471423c7de3137730f3db2 /Makefile.am
parent422ba2a18f6d04eefa0f61f0bb4161e0b5568bb1 (diff)
downloadgzip-ef80dc4ff003105071a6ba7470b30f4ba57e6e8a.tar.gz
tests: port to systems for which ":" is not the PATH separator
* Makefile.am (new_path): New variable. (check-local): Use $(PATH_SEPARATOR) rather than a literal ":", to avoid "make syntax-check" failure.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am19
1 files changed, 11 insertions, 8 deletions
diff --git a/Makefile.am b/Makefile.am
index 8fb17b9..dfed9aa 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -103,18 +103,21 @@ gen-ChangeLog:
mv $(distdir)/cl-t $(distdir)/ChangeLog; \
fi
+# Prepend "." to $PATH:
+new_path = PATH=.$(PATH_SEPARATOR)$$PATH
+
# A simple test, just of gzip -- more of a sanity check than anything else.
FILES_TO_CHECK = $(bin_SCRIPTS) \
$(top_srcdir)/ChangeLog $(top_srcdir)/configure $(top_srcdir)/gzip.c
check-local: $(FILES_TO_CHECK) $(bin_PROGRAMS) gzip.doc.gz
- $(AM_V_GEN)PATH=.:$$PATH; { test '$(srcdir)' != . \
- || zdiff -c gzip.doc.gz; }
- $(AM_V_at)PATH=.:$$PATH; zdiff -c $(srcdir)/gzip.doc $(srcdir)/gzip.doc
- $(AM_V_at)PATH=.:$$PATH; zdiff $(srcdir)/gzip.doc gzip.doc.gz
- $(AM_V_at)PATH=.:$$PATH; zdiff -c - $(srcdir)/gzip.doc <gzip.doc.gz
- $(AM_V_at)PATH=.:$$PATH; zdiff -c gzip.doc.gz gzip.doc.gz
- $(AM_V_at)PATH=.:$$PATH; zgrep -iV >/dev/null
- $(AM_V_at)PATH=.:$$PATH; \
+ $(AM_V_GEN)$(new_path); { test '$(srcdir)' != . \
+ || zdiff -c gzip.doc.gz; }
+ $(AM_V_at)$(new_path); zdiff -c $(srcdir)/gzip.doc $(srcdir)/gzip.doc
+ $(AM_V_at)$(new_path); zdiff $(srcdir)/gzip.doc gzip.doc.gz
+ $(AM_V_at)$(new_path); zdiff -c - $(srcdir)/gzip.doc <gzip.doc.gz
+ $(AM_V_at)$(new_path); zdiff -c gzip.doc.gz gzip.doc.gz
+ $(AM_V_at)$(new_path); zgrep -iV >/dev/null
+ $(AM_V_at)$(new_path); \
for opt in --rsyncable '' -1 -9; do \
for file in $(FILES_TO_CHECK); do \
gzip $$opt -c -- "$$file" \