summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorMarius Vollmer <mvo@zagadka.de>2002-04-17 17:38:41 +0000
committerMarius Vollmer <mvo@zagadka.de>2002-04-17 17:38:41 +0000
commit595f15f48d19d1fb177bad417d9f3bead95d942f (patch)
tree3580f287a4a58b228661d32c844f8001a0ab3f47 /doc/Makefile.am
parenta44e61ac793a7ab443681cfee01797a3b83d75ee (diff)
downloadguile-595f15f48d19d1fb177bad417d9f3bead95d942f.tar.gz
(dist-hook): Simplified to not use "cd"; now it works for relative
pathnames in $(distdir).
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am9
1 files changed, 4 insertions, 5 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 30fa5521a..19e3a1333 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -32,12 +32,11 @@ EXAMPLE_SMOB_FILES = \
OLDFMT = oldfmt.c
dist-hook:
+ cp $(srcdir)/$(OLDFMT) $(distdir)/
mkdir $(distdir)/example-smob
- (cd $(srcdir); \
- cp $(OLDFMT) $(distdir); \
- dest="`cd $(distdir)/example-smob; pwd`"; \
- cd example-smob; \
- cp $(EXAMPLE_SMOB_FILES) $$dest)
+ for f in $(EXAMPLE_SMOB_FILES); do \
+ cp $(srcdir)/example-smob/$$f $(distdir)/example-smob/; \
+ done
# pending the papers from Robert Merkel
# EXTRA_DIST = guile.1