| Commit message (Expand) | Author | Age | Files | Lines |
* | Drop gdk_cairo_surface_upload_to_gl() helper | Alexander Larsson | 2020-09-25 | 1 | -7/+0 |
* | Replace "gdouble" with "double" | Benjamin Otte | 2020-07-25 | 1 | -2/+2 |
* | gdk: Remove gdk_cairo_get_clip_rectangle() | Benjamin Otte | 2020-02-13 | 1 | -4/+0 |
* | Revert "Break out cairo color matrix recoloring to gdk_cairo_image_surface_re... | Benjamin Otte | 2020-02-04 | 1 | -6/+0 |
* | indentation: fix various alignment issues | Alexander Larsson | 2020-01-30 | 1 | -2/+2 |
* | Break out cairo color matrix recoloring to gdk_cairo_image_surface_recolor() | Alexander Larsson | 2020-01-29 | 1 | -0/+6 |
* | Use a single compilation symbol | Emmanuele Bassi | 2019-11-27 | 1 | -1/+1 |
* | gdk: Get rid of GdkDrawingContext | Benjamin Otte | 2018-04-24 | 1 | -1/+0 |
* | gdk: Remove gdk_cairo_surface_create_from_pixbuf() | Benjamin Otte | 2018-04-12 | 1 | -4/+0 |
* | gdk: Remove gdk_cairo_get_drawing_context() | Benjamin Otte | 2018-04-12 | 1 | -3/+0 |
* | GdkSurface: Rename lots of stuff from window->surface | Alexander Larsson | 2018-03-20 | 1 | -1/+1 |
* | GdkSurface: Rename various functions and variables | Alexander Larsson | 2018-03-20 | 1 | -1/+1 |
* | GdkWindow -> GdkSurface initial type rename | Alexander Larsson | 2018-03-20 | 1 | -2/+2 |
* | The big versioning cleanup | Matthias Clasen | 2018-02-06 | 1 | -4/+4 |
* | API: gdk: Remove ability to render window contents | Benjamin Otte | 2016-11-20 | 1 | -5/+0 |
* | Drop GdkColor | Matthias Clasen | 2016-11-01 | 1 | -1/+0 |
* | gdk: Remove deprecated gdk_cairo_set_source_color | Rico Tzschichholz | 2016-10-24 | 1 | -4/+0 |
* | gdk: Add utility for uploading Cairo surfaces to GL | Emmanuele Bassi | 2016-10-18 | 1 | -0/+7 |
* | gdk: Remove old code to create drawing context | Benjamin Otte | 2016-10-16 | 1 | -3/+0 |
* | gdk: Deprecate gdk_cairo_create() | Emmanuele Bassi | 2016-06-09 | 1 | -1/+1 |
* | Associate the drawing context to the Cairo context | Emmanuele Bassi | 2016-06-09 | 1 | -2/+4 |
* | Add frame drawing API to GdkWindow | Emmanuele Bassi | 2016-06-09 | 1 | -0/+2 |
* | gdk: Add support for OpenGL | Alexander Larsson | 2014-10-13 | 1 | -0/+11 |
* | Deprecate GdkColor | Matthias Clasen | 2014-05-22 | 1 | -1/+1 |
* | gdk: Add gdk_cairo_surface_create_from_pixbuf | Alexander Larsson | 2013-07-03 | 1 | -0/+5 |
* | Add GDK_AVAILABLE_IN_ALL annotations in gdk | Matthias Clasen | 2013-05-05 | 1 | -0/+8 |
* | Move single-include guards inside include guards | Matthias Clasen | 2012-12-28 | 1 | -3/+3 |
* | Change FSF Address | Javier Jardón | 2012-02-27 | 1 | -3/+1 |
* | gdk: Use versioned deprecations | Matthias Clasen | 2012-02-27 | 1 | -1/+2 |
* | Deprecate all the public API that is using GdkColor struct | Javier Jardón | 2011-12-22 | 1 | -2/+4 |
* | Revert "Clean up includes" | Matthias Clasen | 2011-11-22 | 1 | -1/+1 |
* | Clean up includes | Matthias Clasen | 2011-11-22 | 1 | -1/+1 |
* | More GDK documentation tweaks | Matthias Clasen | 2011-02-09 | 1 | -23/+23 |
* | Use cairo gobject support instead of a new boxed type. | Benjamin Berg | 2010-12-04 | 1 | -3/+0 |
* | Add a boxed type for cairo_pattern_t. | Carlos Garnacho | 2010-12-04 | 1 | -0/+3 |
* | API: Make gdk_cairo_create() take a GdkWindow | Benjamin Otte | 2010-12-02 | 1 | -1/+1 |
* | API: Remove gdk_cairo_reset_clip() | Benjamin Otte | 2010-12-02 | 1 | -2/+0 |
* | Add GdkRGBA struct to supersede GdkColor | Carlos Garnacho | 2010-10-22 | 1 | -0/+3 |
* | API: add gdk_cairo_get_clip_rectangle() convenience API | Benjamin Otte | 2010-09-26 | 1 | -0/+2 |
* | API: Rename gdk_set_source_pixmap() to gdk_set_source_window() | Benjamin Otte | 2010-09-26 | 1 | -4/+4 |
* | API: Add gdk_cairo_region_create_from_surface() | Benjamin Otte | 2010-09-26 | 1 | -0/+4 |
* | s/GdkRegion/cairo_region_t/ in all of gtk | Benjamin Otte | 2010-06-29 | 1 | -1/+1 |
* | Remove all traces of GDK_PIXBUF/GTK_DISABLE_SINGLE_INCLUDES | Michael Natterer | 2010-05-03 | 1 | -1/+1 |
* | Fix a typo | Matthias Clasen | 2009-09-04 | 1 | -1/+1 |
* | Add gdk_cairo_reset_clip | Alexander Larsson | 2009-09-01 | 1 | -0/+2 |
* | Revert name change | Cody Russell | 2008-07-01 | 1 | -1/+1 |
* | Practically everything changed. | Cody Russell | 2008-06-30 | 1 | -1/+1 |
* | define __GDK_H_INSIDE__ around including all other headers. | Michael Natterer | 2008-05-28 | 1 | -0/+4 |
* | gdk/gdk.h gdk/gdkcairo.h gdk/gdkcolor.h gdk/gdkgc.h gdk/gdkinternals.h | Michael Natterer | 2008-01-14 | 1 | -17/+17 |
* | Add gdk_cairo_set_source_pixmap. (#318805, Alexander Larsson) | Matthias Clasen | 2005-12-30 | 1 | -0/+4 |