summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
authorTing-Wei Lan <lantw@src.gnome.org>2018-04-22 20:47:32 +0800
committerTing-Wei Lan <lantw@src.gnome.org>2018-04-22 21:57:10 +0800
commitf922109a9c684d1fb852b041eccbeb4781b7039a (patch)
tree49b49be29780a0a3d71f48fed297154883e1f886 /tests/meson.build
parent7a09cd4cdaff9c5643ad0e3e212cb2acb8ba9fde (diff)
downloadgtk+-f922109a9c684d1fb852b041eccbeb4781b7039a.tar.gz
build: Make the default setting work on non-Linux Unix-like systems
All of the four platform-dependent backends are enabled by default. It is usually a good default because it requires users to explicitly choose backends they want to use. Rules in meson.build also automatically disable unavailable backends for macOS, Windows, Linux, so users on these 3 major platforms don't have to manually disable things when running meson commands. However, meson.build doesn't do the same thing for other Unix-like systems, which is acceptable but not ideal. To make it easier to build GTK+ on these systems, the Linux case, which enables X11 and Wayland and disables Win32 and Quartz, is made the default for all operating systems that are not Windows or macOS. This commit also changes most 'host_machine.system()' calls to os_* variables, which are easier to read and less likely to be used wrongly.
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/meson.build b/tests/meson.build
index 051fbb1588..772dc23e49 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -133,7 +133,7 @@ gtk_tests = [
['testtexture'],
]
-if os_linux
+if os_unix
gtk_tests += [['testfontchooserdialog']]
endif