summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorOwen Taylor <otaylor@redhat.com>2001-04-03 18:48:46 +0000
committerOwen Taylor <otaylor@src.gnome.org>2001-04-03 18:48:46 +0000
commitaf5c897e4ba03e96ca35f7e8f20438fd9336969d (patch)
treef6f8859aeab270a9f67626962e8ee2ae52973c28 /tests/Makefile.am
parent748560e1fcccc046183f82818960ca53f0b69295 (diff)
downloadgtk+-af5c897e4ba03e96ca35f7e8f20438fd9336969d.tar.gz
Updated.
Tue Apr 3 13:55:37 2001 Owen Taylor <otaylor@redhat.com> * NEWS: Updated. * configure.in: Remove support for uninstalled glib. * gtk/gtkdnd.c (gtk_drag_highlight_expose): Return FALSE as so as not to stop emission. * gtk-config-2.0.in: Exit with an error message that gtk-config-2.0 is no longer supported. * Makefile.am gtk/Makefile.am tests/*: Moved all tests into tests, change build order to build modules before gtk/. * modules/input/Makefile.am: Move gtk-query-immodules-2.0 invocation to here.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am50
1 files changed, 49 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index d60330472b..5c000571e4 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -31,24 +31,72 @@ LDADDS = @STRIP_BEGIN@ \
@STRIP_END@
noinst_PROGRAMS = \
+ simple \
+ testcalendar \
+ testdnd \
+ testgtk \
+ testinput \
+ testrgb \
+ testselection \
## testsocket \
## testsocket_child \
+ testtext \
+ testtextbuffer \
testtreeview \
testtreefocus \
testtreecolumns \
- testtreesort
+ testtreesort \
+ treestoretest
#testsocket_DEPENDENCIES = $(DEPS)
#testsocket_child_DEPENDENCIES = $(DEPS)
+simple_DEPENDENCIES = $(TEST_DEPS)
+testcalendar_DEPENDENCIES = $(TEST_DEPS)
+testdnd_DEPENDENCIES = $(TEST_DEPS)
+testgtk_DEPENDENCIES = $(TEST_DEPS)
+testinput_DEPENDENCIES = $(TEST_DEPS)
+testrgb_DEPENDENCIES = $(TEST_DEPS)
+testselection_DEPENDENCIES = $(TEST_DEPS)
+testtext_DEPENDENCIES = $(TEST_DEPS)
+testtextbuffer_DEPENDENCIES = $(TEST_DEPS)
testtreeview_DEPENDENCIES = $(DEPS)
testtreefocus_DEPENDENCIES = $(DEPS)
testtreecolumns_DEPENDENCIES = $(DEPS)
testtreesort_DEPENDENCIES = $(DEPS)
+treestoretest_DEPENDENCIES = $(TEST_DEPS)
#testsocket_LDADD = $(LDADDS)
#testsocket_child_LDADD = $(LDADDS)
+simple_LDADD = $(LDADDS)
+testcalendar_LDADD = $(LDADDS)
+testdnd_LDADD = $(LDADDS)
+testgtk_LDADD = $(LDADDS)
+testinput_LDADD = $(LDADDS)
+testrgb_LDADD = $(LDADDS)
+testselection_LDADD = $(LDADDS)
+testtextbuffer_LDADD = $(LDADDS)
testtreeview_LDADD = $(LDADDS)
testtreefocus_LDADD = $(LDADDS)
testtreecolumns_LDADD = $(LDADDS)
testtreesort_LDADD = $(LDADDS)
+testtext_LDADD = $(LDADDS)
+treestoretest_LDADD = $(LDADDS)
+
+EXTRA_DIST += @STRIP_BEGIN@ \
+ testgtk.1 \
+ testgtkrc \
+ testgtkrc2 \
+ circles.xbm \
+ 3DRings.xpm \
+ FilesQueue.xpm \
+ Modeller.xpm \
+ check-y.xpm \
+ check-n.xpm \
+ marble.xpm \
+ test.xpm \
+ check-y.xpm \
+ check-n.xpm \
+ test.xpm \
+@STRIP_END@
+