summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.com>2017-03-23 20:50:03 +0000
committerEmmanuele Bassi <ebassi@gnome.org>2017-05-03 15:10:55 +0100
commit5d71390a750fcc9a057b73e8cf252a05eda8e5af (patch)
tree01fcdb0bc76ae23431429cb6b7850a9904d4c88d /meson.build
parent361e5d0b7473ad08de901b6b62f3b1cfbd9e98be (diff)
downloadgtk+-5d71390a750fcc9a057b73e8cf252a05eda8e5af.tar.gz
meson: check for more missing config.h defines
Lots of them are unused and can be removed. For others we add a check.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build25
1 files changed, 6 insertions, 19 deletions
diff --git a/meson.build b/meson.build
index 9afb89bef0..335cffb687 100644
--- a/meson.build
+++ b/meson.build
@@ -122,25 +122,7 @@ endforeach
# Maths functions might be implemented in libm
libm = cc.find_library('m', required : false)
-# check token HAVE_BIND_TEXTDOMAIN_CODESET
-# check token HAVE_CUPS_API_1_6
-# check token HAVE_GETTEXT
-# check token HAVE_GIO_UNIX
-# check token HAVE_GNU_FTW
-# check token HAVE_HTTPGETAUTHSTRING
-# check token HAVE_HTTP_AUTHSTRING
-# check token HAVE_IPRINTDIALOGCALLBACK
-# check token HAVE_LC_MESSAGES
-# check token HAVE_LOCALTIME_R
-# check token HAVE_SOCKADDR_UN_SUN_LEN
-# check token HAVE_SOLARIS_XINERAMA
-# check token HAVE_XFREE_XINERAMA
-# check token HAVE_XINERAMA
-# check token HAVE__NL_MEASUREMENT_MEASUREMENT
-# check token HAVE__NL_PAPER_HEIGHT
-# check token HAVE__NL_PAPER_WIDTH
-# check token HAVE__NL_TIME_FIRST_WEEKDAY
-# check token HAVE__NSGETENVIRON
+# FIXME: HAVE_XFREE_XINERAMA
check_functions = [
'dcgettext',
@@ -330,6 +312,11 @@ endif
mlib = cc.find_library('m', required: false)
+# Check for bind_textdomain_codeset, including -lintl if GLib brings it in
+if cc.has_function('bind_textdomain_codeset', dependencies: glib_dep)
+ cdata.set('HAVE_BIND_TEXTDOMAIN_CODESET', 1)
+endif
+
cdata.set('HAVE_GIO_UNIX', giounix_dep.found())
# Check for Vulkan support