summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2023-05-08 15:43:08 -0400
committerEmmanuele Bassi <ebassi@gnome.org>2023-05-09 16:43:25 +0100
commit5ae25519a72b38dcc36591223258a3ffa382dba9 (patch)
tree8d99f3e4bc90fcaabb0bae06279c7a7c8ca46f85 /meson.build
parent4d1f7a476d9d05e89863764d0c9f7a1fb71b5432 (diff)
downloadgtk+-5ae25519a72b38dcc36591223258a3ffa382dba9.tar.gz
Make it build
Fix the circular dependency by moving the generated headers to gdk/version/, and build that directory first. Misc other fixes, such as putting the custom targets as sources, not depedencies, and using the correct major version in the generator script.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 1 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 28066d8e3a..0c38fcb1ca 100644
--- a/meson.build
+++ b/meson.build
@@ -344,12 +344,10 @@ common_cflags = cc.get_supported_arguments(test_cflags)
if get_option('default_library') != 'static'
if os_win32
cdata.set('DLL_EXPORT', true)
- cdata.set('_GDK_EXTERN', '__declspec(dllexport) extern')
if cc.get_id() != 'msvc'
common_cflags += ['-fvisibility=hidden']
endif
else
- cdata.set('_GDK_EXTERN', '__attribute__((visibility("default"))) extern')
common_cflags += ['-fvisibility=hidden']
endif
endif
@@ -749,6 +747,7 @@ project_build_root = meson.current_build_dir()
gen_visibility_macros = find_program('build-aux/meson/gen-visibility-macros.py')
+subdir('gdk/version')
subdir('gtk/css')
subdir('gdk')
subdir('gsk')