summaryrefslogtreecommitdiff
path: root/gtk/meson.build
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2020-09-29 17:55:01 +0100
committerEmmanuele Bassi <ebassi@gnome.org>2020-10-12 16:19:31 +0100
commitc50916d27be3dd19c97dccdb02b259397e13852c (patch)
tree9a04f88a8ac1c3a6dacfa579c5fd120f59bf25a3 /gtk/meson.build
parent4b60e7470aa6f2ea86c239ee13f4ceaeb563cbb7 (diff)
downloadgtk+-c50916d27be3dd19c97dccdb02b259397e13852c.tar.gz
a11y: Add the AT-SPI DBus descriptions
And generate the code for the DBus interfaces. We don't want the full object manager experience, here, because we're going to have a single object responding to various interfaces and remote method calls. For this reason, we're not using the gnome module in Meson to call gdbus-codegen for us: we need to use the interface info command line arguments, and those are not available from Meson.
Diffstat (limited to 'gtk/meson.build')
-rw-r--r--gtk/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/gtk/meson.build b/gtk/meson.build
index 006ac8f31e..614b4079f8 100644
--- a/gtk/meson.build
+++ b/gtk/meson.build
@@ -1,3 +1,4 @@
+subdir('a11y')
subdir('deprecated')
subdir('inspector')
@@ -961,6 +962,7 @@ gtk_gen_headers = [
]
gtk_sources += [
+ gtk_a11y_src,
gtk_dbus_src,
gtk_deprecated_sources,
inspector_sources,