summaryrefslogtreecommitdiff
path: root/gtk/Makefile.am
diff options
context:
space:
mode:
authorDaiki Ueno <dueno@src.gnome.org>2016-01-06 18:09:04 +0900
committerMatthias Clasen <mclasen@redhat.com>2016-01-07 18:08:30 -0500
commitf9e6ccd59256ef86bdfa3bfe9810df35f7ee00fe (patch)
treea23e2ce8f83ad066b3ef3937dbfbf0e03e1b0b30 /gtk/Makefile.am
parentb1f692572747b2ef39135361bb83624ec38d04d6 (diff)
downloadgtk+-f9e6ccd59256ef86bdfa3bfe9810df35f7ee00fe.tar.gz
gtkbuilder: Install gettext ITS files
Recent gettext has a feature to allow consumer projects to supply their own string extraction rules for XML files, in ITS format. Gettext still ships the rule for *.ui, but it would be better maintained in the upstream project. https://bugzilla.gnome.org/show_bug.cgi?id=760202
Diffstat (limited to 'gtk/Makefile.am')
-rw-r--r--gtk/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/gtk/Makefile.am b/gtk/Makefile.am
index c851656ffd..48815fed92 100644
--- a/gtk/Makefile.am
+++ b/gtk/Makefile.am
@@ -1114,6 +1114,11 @@ pkgdata_DATA = gtkbuilder.rng
EXTRA_DIST += gtkbuilder.rnc gtkbuilder.rng
+itsdir = $(datadir)/gettext/its
+its_DATA = gtkbuilder.loc gtkbuilder.its
+
+EXTRA_DIST += $(its_DATA)
+
templates = \
$(inspector_templates) \
ui/gtkapplication-quartz.ui \