summaryrefslogtreecommitdiff
path: root/gdk/wayland/meson.build
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.com>2017-03-20 00:36:38 +0000
committerEmmanuele Bassi <ebassi@gnome.org>2017-05-03 15:10:54 +0100
commitd4881df0d8c5e69b0341d38ea0a47bb62a0b85b8 (patch)
treeac16ccd344b5e41b273d931c2757eb133aee0261 /gdk/wayland/meson.build
parent4b969b1b405c9babecce598c1f81b29a7159a32c (diff)
downloadgtk+-d4881df0d8c5e69b0341d38ea0a47bb62a0b85b8.tar.gz
meson: gdk: wayland: move wayland bits into wayland subdir
Diffstat (limited to 'gdk/wayland/meson.build')
-rw-r--r--gdk/wayland/meson.build50
1 files changed, 43 insertions, 7 deletions
diff --git a/gdk/wayland/meson.build b/gdk/wayland/meson.build
index 92f0386ab8..5f4b1ba498 100644
--- a/gdk/wayland/meson.build
+++ b/gdk/wayland/meson.build
@@ -1,3 +1,43 @@
+gdk_wayland_sources = files([
+ 'gdkapplaunchcontext-wayland.c',
+ 'gdkcursor-wayland.c',
+ 'gdkdevice-wayland.c',
+ 'gdkdisplay-wayland.c',
+ 'gdkdnd-wayland.c',
+ 'gdkeventsource-wayland.c',
+ 'gdkglcontext-wayland.c',
+ 'gdkkeys-wayland.c',
+ 'gdkmonitor-wayland.c',
+ 'gdkscreen-wayland.c',
+ 'gdkselection-wayland.c',
+ 'gdkvulkancontext-wayland.c',
+ 'gdkwindow-wayland.c',
+ 'wm-button-layout-translation.c',
+])
+
+gdk_wayland_public_headers = files([
+ 'gdkwaylanddevice.h',
+ 'gdkwaylanddisplay.h',
+ 'gdkwaylandglcontext.h',
+ 'gdkwaylandmonitor.h',
+ 'gdkwaylandselection.h',
+ 'gdkwaylandwindow.h'
+])
+
+install_headers(gdk_wayland_public_headers, subdir: 'gtk-4.0/gdk/wayland/')
+install_headers('gdkwayland.h', subdir: 'gtk-4.0/gdk/')
+
+gdk_wayland_deps = [
+ shmlib,
+ xkbdep,
+ wlclientdep,
+ wlprotocolsdep,
+ wlcursordep,
+ wlegldep,
+]
+
+# wayland protocols
+
proto_dir = dependency('wayland-protocols').get_pkgconfig_variable('pkgdatadir')
assert(proto_dir != '', 'Could not get pkgdatadir from wayland-protocols.pc')
@@ -24,22 +64,18 @@ proto_sources = [
join_paths(proto_dir, 'unstable/tablet/tablet-unstable-v2.xml')],
]
-wayland_proto_targets = []
+# FIXME: there's some protostability/protoname stuff in Makefile.am I don't grok
foreach p : proto_sources
output_base = p[0]
input = p[1]
- hdr = custom_target('@0@ client header'.format(output_base),
+ gdk_wayland_sources += custom_target('@0@ client header'.format(output_base),
input : input,
output : '@0@-client-protocol.h'.format(output_base),
command: [genprotocols, wayland_scanner, '@INPUT@', '@OUTPUT@', 'client-header'])
- src = custom_target('@0@ source'.format(output_base),
+ gdk_wayland_sources += custom_target('@0@ source'.format(output_base),
input : input,
output : '@0@-protocol.c'.format(output_base),
command: [genprotocols, wayland_scanner, '@INPUT@', '@OUTPUT@', 'code'])
-
- wayland_proto_targets += [hdr, src]
endforeach
-
-gdk_sources += wayland_proto_targets