summaryrefslogtreecommitdiff
path: root/gdk/Makefile.am
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2011-01-14 09:44:10 -0500
committerMatthias Clasen <mclasen@redhat.com>2011-01-14 09:44:10 -0500
commit9d14edf760153a9ea38f8e7dd3af995be06f4bfb (patch)
treec7687f0425883096b4fa702952fdd5db882cb50b /gdk/Makefile.am
parent8ba35bc38192ce3b4527294758cf8edd8fda6a08 (diff)
downloadgtk+-9d14edf760153a9ea38f8e7dd3af995be06f4bfb.tar.gz
Add --include-uninstalled for the gdk gir
https://bugzilla.gnome.org/show_bug.cgi?id=635287
Diffstat (limited to 'gdk/Makefile.am')
-rw-r--r--gdk/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/gdk/Makefile.am b/gdk/Makefile.am
index dcaeb148f5..8cba98d585 100644
--- a/gdk/Makefile.am
+++ b/gdk/Makefile.am
@@ -185,7 +185,8 @@ introspection_files = \
gdkenumtypes.h
Gdk-3.0.gir: libgdk-3.0.la Makefile
-Gdk_3_0_gir_SCANNERFLAGS = --warn-all --c-include="gdk/gdk.h"
+Gdk_3_0_gir_SCANNERFLAGS = \
+ --c-include="gdk/gdk.h"
Gdk_3_0_gir_INCLUDES = Gio-2.0 GdkPixbuf-2.0 Pango-1.0 cairo-1.0
Gdk_3_0_gir_LIBS = libgdk-3.0.la
Gdk_3_0_gir_FILES = $(introspection_files)
@@ -234,7 +235,10 @@ x11_introspection_files = \
x11/gdkx11window.h
GdkX11-3.0.gir: libgdk-3.0.la Gdk-3.0.gir Makefile
-GdkX11_3_0_gir_SCANNERFLAGS = --warn-all --strip-prefix=Gdk --c-include="gdk/gdkx.h"
+GdkX11_3_0_gir_SCANNERFLAGS = \
+ --strip-prefix=Gdk \
+ --c-include="gdk/gdkx.h" \
+ --include-uninstalled=$(top_builddir)/gdk/Gdk-3.0.gir
GdkX11_3_0_gir_INCLUDES = Gio-2.0 Gdk-3.0 GdkPixbuf-2.0 Pango-1.0 xlib-2.0
GdkX11_3_0_gir_LIBS = libgdk-3.0.la
GdkX11_3_0_gir_FILES = $(x11_introspection_files)