summaryrefslogtreecommitdiff
path: root/examples/Makefile.am
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2010-10-15 12:37:21 -0400
committerMatthias Clasen <mclasen@redhat.com>2010-10-15 13:02:50 -0400
commit0ff28d72f68c25d85fa851fc214f9478d9cb2396 (patch)
treeda6bb8dda1fa3ea3caa30328ab89c2d45ebd13ef /examples/Makefile.am
parentef7fddac3bfecfe855c55b78803df304376136eb (diff)
downloadgtk+-0ff28d72f68c25d85fa851fc214f9478d9cb2396.tar.gz
examples: build examples that are included in the docs
We build the examples that are included in the 'getting started' chapter of the docs to prevent them from bitrotting. Also remove the awk scripts used to extract the old examples from the tutorial, since the tutorial is gone. I'm still leaving the examples themeselves in place, for possible inclusion in 'getting started' later on.
Diffstat (limited to 'examples/Makefile.am')
-rw-r--r--examples/Makefile.am47
1 files changed, 47 insertions, 0 deletions
diff --git a/examples/Makefile.am b/examples/Makefile.am
new file mode 100644
index 0000000000..e5a9f8d876
--- /dev/null
+++ b/examples/Makefile.am
@@ -0,0 +1,47 @@
+
+DIST_SUBDIRS = arrow \
+ aspectframe \
+ base \
+ buttonbox \
+ buttons \
+ calendar \
+ entry \
+ eventbox \
+ fixed \
+ frame \
+ gtkdial \
+ helloworld \
+ helloworld2 \
+ label \
+ menu \
+ notebook \
+ packbox \
+ paned \
+ progressbar \
+ radiobuttons \
+ rangewidgets \
+ rulers \
+ scribble-simple \
+ scribble-xinput \
+ scrolledwin \
+ selection \
+ spinbutton \
+ statusbar \
+ table \
+ tictactoe
+# wheelbarrow
+
+INCLUDES = \
+ -I$(top_srcdir) \
+ -I$(top_srcdir)/gdk \
+ -DGDK_DISABLE_DEPRECATED \
+ -DGTK_DISABLE_DEPRECATED \
+ $(GTK_DEBUG_FLAGS) \
+ $(GTK_DEP_CFLAGS)
+
+LDADD = \
+ $(top_builddir)/gdk/$(gdktargetlib) \
+ $(top_builddir)/gtk/$(gtktargetlib) \
+ $(GTK_DEP_LIBS)
+
+bin_PROGRAMS = hello-world window-default