summaryrefslogtreecommitdiff
path: root/demos/Makefile.am
diff options
context:
space:
mode:
authorTim Janik <timj@gtk.org>2001-06-26 08:32:25 +0000
committerTim Janik <timj@src.gnome.org>2001-06-26 08:32:25 +0000
commitbf0d61a59b9e1b889ba98b36b05a90e76f64eced (patch)
treefe8a750554c398b744dbfd4b99eb617122344b00 /demos/Makefile.am
parent0e0ee24bea94062f9dc3d82007cc5184a7f79b3a (diff)
downloadgtk+-bf0d61a59b9e1b889ba98b36b05a90e76f64eced.tar.gz
use gdk_pixbuf_new_from_stream(). fixed up item factory so inlined pixbufs
Tue Jun 26 10:04:30 2001 Tim Janik <timj@gtk.org> * gtk/gtkiconfactory.c: * gtk/gtkitemfactory.c: use gdk_pixbuf_new_from_stream(). fixed up item factory so inlined pixbufs actually work. Tue Jun 26 09:48:02 2001 Tim Janik <timj@gtk.org> * Makefile.am (noinst_PROGRAMS): get rid of make-inline-pixbuf * gdk-pixbuf-data.[hc]: provide gdk_pixbuf_new_from_stream() instead from gdk_pixbuf_new_from_inline(). * gdk-pixdata.[hc]: auxillary GdkPixdata structure, public installed API for applications that need to serialize/deserialize on their own (gimp, BEAST). * gdk-pixbuf/gdk-pixbuf-csource.c: provide publically installed program that can dump images in CSource format and Pixbuf stream format. supports RLE encoding, MACRO formatting etc... invoke with --help.
Diffstat (limited to 'demos/Makefile.am')
-rw-r--r--demos/Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/demos/Makefile.am b/demos/Makefile.am
index 25eba72653..5bcf5023cb 100644
--- a/demos/Makefile.am
+++ b/demos/Makefile.am
@@ -32,10 +32,12 @@ noinst_PROGRAMS = \
BUILT_SOURCES=test-inline-pixbufs.h
-test-inline-pixbufs.h: $(top_builddir)/gdk-pixbuf/make-inline-pixbuf apple-red.png gnome-foot.png
+test-inline-pixbufs.h: $(top_builddir)/gdk-pixbuf/gdk-pixbuf-csource apple-red.png gnome-foot.png
(topdir=`cd $(top_builddir) && pwd` ; curdir=`pwd` ; \
- cd $(srcdir) && \
- GDK_PIXBUF_MODULEDIR=$$topdir/gdk-pixbuf/.libs $$topdir/gdk-pixbuf/make-inline-pixbuf $$curdir/test-inline-pixbufs.h apple_red apple-red.png gnome_foot gnome-foot.png)
+ cd $(srcdir) && \
+ GDK_PIXBUF_MODULEDIR=$$topdir/gdk-pixbuf/.libs \
+ $$topdir/gdk-pixbuf/gdk-pixbuf-csource --build-list \
+ apple_red apple-red.png gnome_foot gnome-foot.png >$$curdir/test-inline-pixbufs.h)
testpixbuf_DEPENDENCIES = $(DEPS)
testpixbuf_drawable_DEPENDENCIES = $(DEPS)