summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorHavoc Pennington <hp@pobox.com>2001-09-21 14:23:15 +0000
committerHavoc Pennington <hp@src.gnome.org>2001-09-21 14:23:15 +0000
commit85b433515b43064e51f820e9971b257ae71275c3 (patch)
treebe304951b9b5cdd9d697425f562f119e81777e96 /configure.in
parentbd30ca18847e96b3b1d51f91b905eb6540e5969b (diff)
downloadgtk+-85b433515b43064e51f820e9971b257ae71275c3.tar.gz
add variables and checks for specific versions of dependencies. Previously
2001-09-20 Havoc Pennington <hp@pobox.com> * configure.in (PANGO_REQUIRED_VERSION) (ATK_REQUIRED_VERSION): add variables and checks for specific versions of dependencies. Previously we didn't verify the Pango or ATk versions. 2001-09-09 Havoc Pennington <hp@pobox.com> * gtk/gtktextiter.c: fool with indentation (gtk_text_iter_in_range): add g_return_if_fail
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 13 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index ec143158cc..4961c8402c 100644
--- a/configure.in
+++ b/configure.in
@@ -77,6 +77,11 @@ AC_SUBST(GDK_PIXBUF_MINOR)
AC_SUBST(GDK_PIXBUF_MICRO)
AC_SUBST(GDK_PIXBUF_VERSION)
+## Versions of dependencies
+GLIB_REQUIRED_VERSION=1.3.8
+PANGO_REQUIRED_VERSION=0.19
+ATK_REQUIRED_VERSION=0.4
+
# For automake.
VERSION=$GTK_VERSION
PACKAGE=gtk+
@@ -192,6 +197,14 @@ changequote([,])dnl
# Honor aclocal flags
ACLOCAL="$ACLOCAL $ACLOCAL_FLAGS"
+## Initial sanity check, done here so that users get told they
+## have the wrong dependencies as early in the process as possible.
+## Later on we actually use the cflags/libs from separate pkg-config
+## calls. Oh, also the later pkg-config calls don't include
+## the version requirements since those make the module lists
+## annoying to construct
+PKG_CHECK_MODULES(BASE_DEPENDENCIES, glib-2.0 >= $GLIB_REQUIRED_VERSION atk >= $ATK_REQUIRED_VERSION pango >= $PANGO_REQUIRED_VERSION)
+
# libtool option to control which symbols are exported
# right now, symbols starting with _ are not exported
LIBTOOL_EXPORT_OPTIONS='-export-symbols-regex "^[[^_]].*"'
@@ -295,7 +308,6 @@ AC_TRY_COMPILE([#include <dirent.h>], [DIR *dir;],
#
GLIB_PACKAGES="gobject-2.0 gmodule-2.0"
-GLIB_REQUIRED_VERSION=1.3.8
AM_PATH_GLIB_2_0($GLIB_REQUIRED_VERSION, :,
AC_MSG_ERROR([