summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJavier Jardón <jjardon@gnome.org>2011-02-06 22:19:23 +0000
committerJavier Jardón <jjardon@gnome.org>2011-02-13 11:09:49 +0000
commitefeade2a06dbf24343a378c9384a2eeaf1739755 (patch)
tree27aee6fe38834dedbb1769faab7f313b89d664ff /configure.ac
parentd5872527e5014ffb670b0421cbd5d2ad2fc0f14a (diff)
downloadgtk+-efeade2a06dbf24343a378c9384a2eeaf1739755.tar.gz
configure.ac: Use AC_RUN_IFELSE instead deprecated AC_TRY_RUN
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac30
1 files changed, 14 insertions, 16 deletions
diff --git a/configure.ac b/configure.ac
index 794f5947c1..c29d973b99 100644
--- a/configure.ac
+++ b/configure.ac
@@ -596,22 +596,20 @@ AC_MSG_CHECKING([for extra flags to get ANSI library prototypes])
gtk_save_LIBS=$LIBS
LIBS="$LIBS -lm"
-AC_TRY_RUN([#include <math.h>
- int main (void) { return (log(1) != log(1.)); }],
- AC_MSG_RESULT(none needed),
- gtk_save_CFLAGS="$CFLAGS"
- CFLAGS="$CFLAGS -std1"
- AC_TRY_RUN([#include <math.h>
- int main (void) { return (log(1) != log(1.)); }],
- AC_MSG_RESULT(-std1),
- AC_MSG_RESULT()
- CFLAGS="$gtk_save_CFLAGS"
- AC_MSG_WARN(
- [No ANSI prototypes found in library. (-std1 didn't work.)]),
- true
- ),
- AC_MSG_RESULT(none needed)
-)
+AC_RUN_IFELSE([AC_LANG_SOURCE([[#include <math.h>
+ int main (void) { return (log(1) != log(1.)); }]])],
+ [AC_MSG_RESULT(none needed)],
+ [gtk_save_CFLAGS="$CFLAGS"
+ CFLAGS="$CFLAGS -std1"
+ AC_RUN_IFELSE([AC_LANG_SOURCE([[#include <math.h>
+ int main (void) { return (log(1) != log(1.)); }]])],
+ [AC_MSG_RESULT(-std1)],
+ [AC_MSG_RESULT()
+ CFLAGS="$gtk_save_CFLAGS"
+ AC_MSG_WARN([No ANSI prototypes found in library. (-std1 did not work.)])],
+ [true])],
+ [AC_MSG_RESULT(none needed)])
+
LIBS=$gtk_save_LIBS
AC_MSG_CHECKING(for the BeOS)