summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDominique Leuenberger <dimstar@opensuse.org>2016-11-24 19:50:34 +0100
committerDominique Leuenberger <dimstar@opensuse.org>2016-11-24 19:53:36 +0100
commitcae8fc74ac384efea24fa0625d6d5f76be612b99 (patch)
tree9a84ff7ed814ac8ea10b8962453c60bd2eabc662 /configure.ac
parent624e0e140948f7cdeef1225bb48fd03909772eb8 (diff)
downloadgtk+-cae8fc74ac384efea24fa0625d6d5f76be612b99.tar.gz
Build: Add wayland to GSKs dependencies
gskrenderer.c includes gdk/wayland/gdkwayland.h and as a consequence we need to be able to locate wayland's headers in case they are not in standard location. https://bugzilla.gnome.org/show_bug.cgi?id=775038
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 83110e7666..8ea6556194 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1374,7 +1374,7 @@ GSK_EXTRA_LIBS=
GSK_EXTRA_CFLAGS=
GSK_PACKAGES="gdk-pixbuf-2.0 >= gdk_pixbuf_required_version cairo >= cairo_required_version cairo-gobject >= cairo_required_version graphene-1.0 >= graphene_required_version"
-GSK_PRIVATE_PACKAGES="epoxy >= epoxy_required_version"
+GSK_PRIVATE_PACKAGES="epoxy >= epoxy_required_version $WAYLAND_PACKAGES"
PKG_CHECK_MODULES(GSK_DEP, $PANGO_PACKAGES $GSK_PACKAGES $GSK_PRIVATE_PACKAGES)
GSK_DEP_LIBS="$GSK_EXTRA_LIBS $GSK_DEP_LIBS $MATH_LIB"