summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChun-wei Fan <fanchunwei@src.gnome.org>2017-02-15 14:43:15 +0800
committerChun-wei Fan <fanchunwei@src.gnome.org>2017-02-15 14:43:15 +0800
commitba4e2a775cb41d3c1bf09d95bcee0add725aa510 (patch)
tree92aeb74561d6eff61c87ff850a5b76b39209bd83 /configure.ac
parent5d390526d340c89a006a80b002636eae0de2f83d (diff)
downloadgtk+-ba4e2a775cb41d3c1bf09d95bcee0add725aa510.tar.gz
Visual Studio builds: Support Visual Studio 2017
Update the autotools scripts to support Visual Studio 2017 builds by copying the Visual Studio 2013 projects and updateing the items as necessary to obtain the Visual Studio 2017 projects. Note that the format of the toolset string changed, so allow one to pass in and thus use a custom toolset string, otherwise the default toolset string will be generated as it was before. Note also the Visual Studio 2017 aims to be compatible with Visual Studio 2015 on the CRT level, so binaries built with 2017 should work without problems with the binaries built with 2015.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c902f57084..8f41e77520 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1969,6 +1969,12 @@ if test "x${enable_Bsymbolic}" = "xyes" ; then
fi
AC_SUBST(GTK_LINK_FLAGS)
+dnl
+dnl Check whether MSVC toolset is explicitly set
+dnl
+AM_CONDITIONAL(MSVC_BASE_NO_TOOLSET_SET, [test x$MSVC_BASE_TOOLSET = x])
+AM_CONDITIONAL(MSVC_NO_TOOLSET_SET, [test x$MSVC_TOOLSET = x])
+
AC_CONFIG_FILES([
README
INSTALL
@@ -2025,6 +2031,7 @@ win32/Makefile
win32/vs12/Makefile
win32/vs12/gtk4-version-paths.props
win32/vs14/Makefile
+win32/vs15/Makefile
gdk/Makefile
gdk/broadway/Makefile
gdk/x11/Makefile