summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2017-03-14 16:35:58 +0000
committerEmmanuele Bassi <ebassi@gnome.org>2017-04-01 15:36:27 +0100
commit99c79d67690dda5fe857c91aac20d0c906d6aa00 (patch)
tree737b24400f5ed994d9bcb9cab6ae7c57e7622153 /configure.ac
parentd55249c6f1b4a02876a79280b832c1f2f9627891 (diff)
downloadgtk+-99c79d67690dda5fe857c91aac20d0c906d6aa00.tar.gz
Optionally depend on sassc to generate the theme CSS
Instead of using Ruby/Sass to generate the CSS from SCSS files, we can use the faster and more lightweight libsass/sassc binary. We can keep the CSS files in Git to make it easier to dist GTK+, but we can add rules to ensure they get rebuilt if the source SCSS changes. https://bugzilla.gnome.org/show_bug.cgi?id=780041
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 45313193c6..9be280972a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1869,6 +1869,14 @@ esac
AC_SUBST(GDK_HIDDEN_VISIBILITY_CFLAGS)
##################################################
+# Theming
+##################################################
+
+AC_PATH_PROG([SASSC], [sassc])
+AC_ARG_VAR(SASSC)
+AM_CONDITIONAL([REBUILD_SCSS], [test "xSASSC" != x])
+
+##################################################
# Output commands
##################################################