summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBenjamin Otte <otte@redhat.com>2016-12-09 21:17:27 +0100
committerBenjamin Otte <otte@redhat.com>2016-12-09 21:27:29 +0100
commit3e9811d91cf0c4e1101b1eed913c950819ad55fd (patch)
tree14e5cb1378672fa9d49b033e9d65f9753a02ebbf /configure.ac
parent4ae50bf38ebe589e88ef37f63ebdf36e030f1aae (diff)
downloadgtk+-3e9811d91cf0c4e1101b1eed913c950819ad55fd.tar.gz
build: Don't try to detect vulkan library if the header wasn't found.
We've already failed. No need to fail again.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index b0d37674bf..59886962f3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1323,8 +1323,9 @@ fi
if test "x$enable_vulkan" != "xno"; then
vulkan_error=""
- AC_CHECK_HEADER([vulkan/vulkan.h], [], [vulkan_error="Vulkan header not found"])
- AC_CHECK_LIB([vulkan], [vkCreateInstance], [], [vulkan_error="Vulkan library not found"])
+ AC_CHECK_HEADER([vulkan/vulkan.h],
+ [AC_CHECK_LIB([vulkan], [vkCreateInstance], [], [vulkan_error="Vulkan library not found"])],
+ [vulkan_error="Vulkan header not found"])
if test "x$vulkan_error" != "x"; then
if "x$enable_vulkan" = "xyes"; then
AC_MSG_ERROR($vulkan_error)