summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2014-11-30 19:24:07 -0500
committerMatthias Clasen <mclasen@redhat.com>2014-11-30 19:24:07 -0500
commit603b49814fb0a4d5e4d23606c365c2949442047e (patch)
tree5b724dfc74a6c0ed2ee28627d8468434d06add9d /Makefile.am
parent09e6fab1c9e3978b1c2f83bd593372f25a14f343 (diff)
downloadgtk+-603b49814fb0a4d5e4d23606c365c2949442047e.tar.gz
Generate README and INSTALL from configure
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am18
1 files changed, 6 insertions, 12 deletions
diff --git a/Makefile.am b/Makefile.am
index 37bc9ff90e..f1f12e6857 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -9,11 +9,13 @@ ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
EXTRA_DIST += \
autogen.sh \
HACKING \
+ README \
+ INSTALL \
NEWS.pre-1-0 \
- README.commits \
+ README.commits \
README.win32 \
config.h.win32 \
- makefile.msc \
+ makefile.msc \
gtk-zip.sh.in \
sanitize-la.sh \
po/README.translators \
@@ -88,19 +90,11 @@ ChangeLog:
echo A git checkout and git-log is required to generate this file >> $@); \
fi
+.PHONY: ChangeLog
+
uninstall-local:
rm -f $(DESTDIR)$(pkgconfigdir)/gtk+-3.0.pc
-dist-hook:
- if test -f $(srcdir)/INSTALL.in && test -f $(srcdir)/README.in ; then \
- CONFIG_FILES="INSTALL:$(srcdir)/INSTALL.in README:$(srcdir)/README.in" \
- CONFIG_HEADERS= \
- $(SHELL) config.status \
- && cp INSTALL README $(distdir) ; \
- fi
-
-.PHONY: ChangeLog
-
DISTCHECK_CONFIGURE_FLAGS = \
--enable-gtk-doc \
--disable-doc-cross-references \