summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2016-08-03 11:52:08 +0100
committerEmmanuele Bassi <ebassi@gnome.org>2016-08-03 11:52:08 +0100
commit445286c2c3fdb7a3c246491da8ceb2a82c07dfd4 (patch)
treefbd75b4a246c7b811cfa285da98a9f760e16fa55 /Makefile.am
parent9e1afd7ba8dfc0edade1f8af7bd0635067589133 (diff)
downloadgtk+-445286c2c3fdb7a3c246491da8ceb2a82c07dfd4.tar.gz
Modify git.mk to handle our split NLS directories
GTK+ has two directories for translations: the default 'po' and the additional 'po-properties' for the GObject properties translation domain. Since the content of the translations directories are filled by autoreconf and gettext, and are duplicated between the two gettext domains we use, we should handle this ad hoc inside git.mk, instead of trying to catch up by adding po-properties files in GITIGNOREFILES.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 2 insertions, 8 deletions
diff --git a/Makefile.am b/Makefile.am
index 0e9eeff49f..86f773a1d4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -104,13 +104,7 @@ AM_DISTCHECK_CONFIGURE_FLAGS = \
--enable-introspection \
--enable-installed-tests
-GITIGNOREFILES = \
- po-properties/Makefile.in.in \
- po-properties/Makefile.in \
- po-properties/Makefile \
- po-properties/*.gmo \
- po-properties/*.mo \
- po-properties/POTFILES \
- po-properties/stamp-it
+GITIGNORE_TRANSLATION_DIRS = po-properties
+GITIGNOREFILES = po-properties/gtk30-properties.pot
-include $(top_srcdir)/git.mk