summaryrefslogtreecommitdiff
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorAntonio Ospite <ao2@ao2.it>2016-11-03 10:30:53 +0100
committerTim-Philipp Müller <tim@centricular.com>2016-11-23 09:09:05 +0000
commit2a5a8dd3c7461b45e25abaaf16cce43eb0d10ecf (patch)
tree2184adfdad3a0ad8d0ee83c053e4a7e7ec3f7c49 /tools/Makefile.am
parent3eb48964358149f9934656f681402a431b262e5f (diff)
downloadgstreamer-2a5a8dd3c7461b45e25abaaf16cce43eb0d10ecf.tar.gz
tools: ship the final man pages directly, no more man pages templates
Don't use templates for the man pages, the API version change is a rare event, so it's not really worth keeping in place the "sed" boilerplate to have it set at build time. Shipping the final man pages directly also makes it easer to install the man pages with meson (in a future commit). Note that now all the occurrences of the programs names have the API version as a suffix. Traditionally the example command lines looked like: gst-launch ... Now they look like: gst-launch-1.0 ... This reflects the actual programs names and makes it easier to copy and paste the example commands. Also, the .gitignore file is adjusted not to ignore the final man pages anymore. You may need to clean your src/build directory before pulling in this patch. https://bugzilla.gnome.org/show_bug.cgi?id=773917
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am14
1 files changed, 1 insertions, 13 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index ffea17d58d..8f807347e5 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -41,16 +41,4 @@ noinst_SCRIPTS = gst-indent
noinst_HEADERS = tools.h
EXTRA_DIST = \
- $(noinst_SCRIPTS) \
- gst-inspect.1.in \
- gst-launch.1.in \
- gst-typefind.1.in
-
-%-@GST_API_VERSION@.1: %.1.in
- $(AM_V_GEN)sed \
- -e s,gst-inspect,gst-inspect-@GST_API_VERSION@,g \
- -e s,gst-launch,gst-launch-@GST_API_VERSION@,g \
- -e s,gst-typefind,gst-typefind-@GST_API_VERSION@,g \
- -e s,GST_API_VERSION,@GST_API_VERSION@,g \
- $< >$@
-
+ $(noinst_SCRIPTS)