summaryrefslogtreecommitdiff
path: root/plugins/Makefile.am
diff options
context:
space:
mode:
authorAlessandro Decina <alessandro.d@gmail.com>2011-01-27 14:33:08 +0100
committerEdward Hervey <edward.hervey@collabora.co.uk>2011-04-11 01:08:07 +0200
commit3f1ef2255a2e7c316d7c877d3a3f6bb815bc79a4 (patch)
treedc13fabd25c99107f7f8de66de9758b7d8dcc2ea /plugins/Makefile.am
parent76559d4160766951348b2303224b943499ac7ee4 (diff)
downloadgstreamer-3f1ef2255a2e7c316d7c877d3a3f6bb815bc79a4.tar.gz
android: make it ready for androgenizer
Remove the android/ top dir Fixe the Makefile.am to be androgenized To build gstreamer for android we are now using androgenizer which generates the needed Android.mk files. Androgenizer can be found here: http://git.collabora.co.uk/?p=user/derek/androgenizer.git
Diffstat (limited to 'plugins/Makefile.am')
-rw-r--r--plugins/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/plugins/Makefile.am b/plugins/Makefile.am
index 90b6580336..6fc0a1b967 100644
--- a/plugins/Makefile.am
+++ b/plugins/Makefile.am
@@ -1,3 +1,8 @@
SUBDIRS = elements indexers
DIST_SUBDIRS = elements indexers
+
+Android.mk: Makefile.am
+ androgenizer -:PROJECT gstreamer \
+ -:SUBDIR $(patsubst %,plugins/%, $(SUBDIRS)) \
+ > $@