summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorStéphane Cerveau <scerveau@collabora.com>2021-10-19 12:32:32 +0200
committerGStreamer Marge Bot <gitlab-merge-bot@gstreamer-foundation.org>2022-01-31 11:04:26 +0000
commitfb1c0626268e7bb4651795bf5651c4c7ea1306d2 (patch)
tree42b983ceed1a0eb07ea0c7e46aff162bb1ca8bf6 /meson.build
parent16dc8f8442352f0531902b8556a477bf186c0343 (diff)
downloadgstreamer-fb1c0626268e7bb4651795bf5651c4c7ea1306d2.tar.gz
gstreamer-full: warn if version-script not available
Instead of error out, warn user that the platform does not support the version script. Part-of: <https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/1191>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 0ff3e479da..174e71695f 100644
--- a/meson.build
+++ b/meson.build
@@ -328,7 +328,7 @@ if get_option('default_library') == 'static'
elif cc.get_id() == 'msvc'
warning('FIXME: Provide a def file to publish the public symbols')
else
- error('Failed to link with version script (' + symbol_map + '), check logs for details')
+ warning('FIXME: Linker does not support the supplied version script (' + symbol_map + '), please disable the "gst-full-version-script" option')
endif
endif